Appliance for Raspberry Pi 4: Error reporting problem: Connection issue with service

Hi there,
today I tried for the first time to report a problem via my appliances Web GUI “Report problem”. After writing down the issue in the text field I pressed the “Submit” button. This resulted in “Error reporting problem: Connection issue with service”. I tried it again several times but I had no luck. Perhaps it has something to to with this issue Appliance for Raspberry Pi 4: Appliance missing in account after reset system to factory conditions followed by new setup ?
However, does anyone have a hint on how I could fix this issue?

Sry, this should be fixed with the latest appliance version.

Hello uroni,
I have now the Infscape UrBackup Appliance 1.10.6 and just had a look in but there my appliance is still not (re)registered nor the clouddrive is. Only the encryption keys are there. Is there a way how I could start the (re)registration from my appliance?
Also, trying to submit a problem report via appliance Web GUI form yielded again “Error reporting problem: Internal problem report issue”.