Appliance for Raspberry Pi 4: Appliance missing in account after reset system to factory conditions followed by new setup

Hi there,
this morning I reset my appliance to factory conditions. Before doing that I went to my account on an deleted there the appliance, the cloud drive and all disk encryption keys. Then I reset my appliance to factory default and set it up again using the same appliance name, license key, etc. as before.
Now, looking into my account I just find all three disk encryption keys but neither the cloud drive nor the appliance is listed there. However, my appliance is fully working.
How could I get my appliance back into my monitoring account?
Thanks in advance for a hint.

Still no luck with My appliance and the cloud drive are still missing in my account. I have no idea how to enable or re-register it. I tried in Settings >>Monitoring to disable and the re-enable the monitoring and faced an alert box “Sorry, an error while saving the settings occurred: Device not found”. Even here I have no idea what or which device could not be found. Does anyone have a hint for me?