Write failed. errno=28


#1

Hi Guys!

I tried to restore a Windows machine, but I get this error:
Write failed. errno=28
writing to output file failed.

Could you somone help me, what is the wrong?

Regards!


#2

Hello,

I have the same problem.
I try to restore whole drive, which contains two Windows volumes (C and D). Restoration of C volume completes successfully. When I try to restore volume D, I get exactly the same error message. No matter target disk already contains volume C or it is absolutely empty.
Does anybody knows a solution?

Regards,
Pavel.


#3

Same here…and this is bad…I have 400 PC’s using UrBackup and if I get this error on all restores I am screwed, as I pushed ahead this software in my company against the will of some of my bosses …


#4

Could you please post more details?

Previous posters said, that it is a second partition (D). In that case the partition table would be helpful (e.g. with parted).

On the Restore cd you can switch to a console (CTRL+ALT+F2) and inspect the log files in /root.

You can also try to reproduce the issue with the command line restore: https://urbackup.atlassian.net/wiki/spaces/US/pages/2981890/How+to+restore+via+command+line


#5

Awsome, yes the problem is on the second partition. C drive works ok but when restoring D partition I get that error. Will try command line restore to see if anything changes. Thanks a lot for the fast reply


#6

Too bad, same result using command line restore, backup fails…it just creates an 1KB partition and try’s to write the whole D partition on that partition and fails as there is not enough space…


#7

You still haven’t clarified what is going on? Why is there a 1KB partition?


#8

I don’t know why there is a 1KB partition, I just see that instead of creating the 8GB “D” partition it creates a 1KB partition and then it starts to write back the data on that partition but obviously it can’t and hence the “not enough space” error…


#9

Hi

more clearly , can you type CTRL+ALT+F2 (that ll switch to console)
then type : parted -l (that ll show the partitions ),
then type : lsblk (that ll also show the partitions, but differently ),
please screenshot that and post it on the forums
then either

transfert the files in /root/ and post them on the forums

or if you have no idea how to do that, then.

type ls -1 /root/ to show the list of files
then : cat /root/
then screenshot that and upload it


#10

You could also upload the .mbr file. That would allow us to look at the partition table as well.


#11

Now I have the exactly same error on 2nd PC…here are the screen shots and .mbr file from both

Urbackup mbr.zip (1.3 KB)

Sorry but I am not very linux oriented just know some basics :slight_smile:


#12

I’d have to have a detailed look at the mbr file if this isn’t the case, but it looks like you are trying to restore a extended partition. Those are not completely supported (see Limitations at https://www.urbackup.org/features.html ).

What you can do is use parted, cfdisk or a boot disk with gparted and create the D partition manually, then restore it via the command line. Just make sure the manually created D partition is large enough.


#13

Sure the mbr file are attached to previous post in zip file

https://forums.urbackup.org/uploads/default/original/2X/5/5d65e609906ee8d0a973d01992c3c5e4aa7cc9be.zip