Windows - migrate_storage_to "ERROR: LMDB: Failed to open LMDB database file..."

I seem to be having the same or similar problem as documented in this post from a few years ago, but the workaround is not taking:

Running UrBackup Server 2.5.30 (updating from 2.5.28 did not improve the situation) on Windows Server 2019.

I am attempting to migrate from a maxed out 16TB NTFS drive with a 4KB cluster size to a new NTFS drive with 30TB. I’ve tried multiple different cluster sizes, and even a drive with the exact same settings as the current backup drive and the log always only shows this, even on debug level:

2023-03-07 14:17:44: ERROR: LMDB: Failed to open LMDB database file (There is not enough space on the disk.
2023-03-07 14:17:44: ERROR: Error opening inode db

The migrate_storage_to file exists and points to a directory on the new, clean 30TB NTFS drive. The inode_db folder is created, as are the two files, inode_db.lmdb at 8KB and inode_db.lmdb-lock at 256KB. The permissions are all defaulted, but files can be read and written to the drive.

Any assistance would be greatly appreciated.

Set map_size for LMDB · Issue #206 · NVIDIA/DIGITS · GitHub suggests that it also needs to reserve that much memory, idk why it worked on my machine then, though, maybe that changed with the most recent Windows versions?

So maybe add a large (managed) swap space on that disk?

Well, it turned out to not be a memory issue, but checking the virtual memory did hint at the real problem. The maximum swap file size Windows wanted to allocate was only around 10GB on the new drive. While trying to figure out what the problem was, I happened to check Get-StorageJob in PowerShell and noticed that there was an optimize job running for the storage pool. After waiting a while, I restarted the UrBackup service and it was able to successfully create the inode database at the mentioned 1TB, so I suppose Windows just hadn’t finished allocating the drive yet even though it was letting me work with it.

Thanks for the help and sorry for the confusion!