Why is C:\Programdata not backed up?

None of my clients does a backup of the folder c:\programdata - although this folder is not in exclusion list.


Maybe it should be c:ProgramData

Data has a capital

No. This is not the reason.

I have no includes defined. So there cannot be a misspell.

I have defined that the whole drive c should be backed up - except some excludes. And C:\ProgramData is not in the excludes.

So I expect that everything - except the excludes - is backed up.

But ProgramData is not backed up - at no client I use urbackup on. All Clients have the same problem.

It is a hidden directory. I would specifically include c:\programdata or perhaps c:\programdata$

Wouldn’t make much sense for a backup system if one had to add all hidden (sub-)directories manually into the include list.

I gave it a try and added c:\ProgrammData to include. After that, my backups were 0 bytes “big” - nothing was backed up. After emptying the include list backups go as normal (and again without C:\ProgrammData).

Any ideas?

Some modifications on ACL perhaps (remove of system acount) ?

Don’t think so. As I wrote in my first post:

“None of my clients does a backup of the folder c:\programdata”

So the ACLs had to change on every client - not very likely.

Did you have allow client to change what folders to backup enabled at any time? If you have, & they changed anything, or you set things when installing the client it’ll ignore the settings on the server, even if you set not to allow it & get settings from the server. At least, that was the behaviour way back when I set up.

Long time since I installed my clients, I forget exactly how to fix that.

I also forget what’s in the default excludes, mine are all changed since I only target C:\Users so I can’t look, & they don’t appear to be listed in the administration manual.

Just checked one of my clients and the settings for it are applied at the Group level with nothing set as Include locations:

For me, this is available when I browse the backup from the GUI to check:

Perhaps you have a new client that can be set up in a new group, and check after it does a backup…?