When backuping: Assertion failed: Unsupported .eh_frame_hdr version


#1

I’ve got a client running on an synology nas. So far that worked well. But the client started crashing when backuping. It manages to backup a lot, but somewhen (it seems to be at random and not always the same file), the backup crashes with:
2018-06-07 01:04:06: FileSrv: Received data…
2018-06-07 01:04:06: FileSrv: Received a Packet.
2018-06-07 01:04:06: FileSrv: Sending file (normal) H1jGCY2vfbLJ8XA5nT6B|volume1/photo/Bilder Geschäft 2017/Tschudin Rosa Nuglar/06.12.2017 024.jpg metadata_id=571525
2018-06-07 01:04:06: FileSrv: Mapped name: /mnt/volume1/photo/Bilder Geschäft 2017/Tschudin Rosa Nuglar/06.12.2017 024.jpg
Assertion failed: Unsupported .eh_frame_hdr version (…/…/src/c++/libunwind/src/EHHeaderParser.hpp: decodeEHHdr: 62)

There is nothing written in the logfile, I only managed to get that message by runing the backup daemon directly on the console and using the parameter “-v debug”.
Client version is 2.2.6. There was the same problem with 2.2.5 .
Last year (with an older version, don’t ask me which one), that worked without any problems on the same device.


#2

Now, after restarting the client and resuming the backup like 10 times, it managed to finish the backup. It always crashed because of the same reason, but on different files. Sometimes after a few hours of backuping, sometimes after a few minutes. But since at the end it managed to finish the backup, it doesn’t seem to be an issue with the file itself.