Weird behavior with clients in different subnet

Hey all,

I looked for similiar topics but couldn’t find a thread where people reported the same.

I’m having 2 subnets within the same physical network. Traffic is going back and forth as configured. I’m aware the server is not able to reach the clients by itself so I added them as “lokal / passive” client. After a while they appear in the client list with status “online” but also still exist in the discovery list with status “offline” and never disappear there. The moment I delete them in the discovery list, they go offline in the client list. Also a “urbackupclientctl status” on the client is saying “no server”. The moment i add them to the discovery list again they coming online and everything is fine. I reproduced it on a different sever with an installation from scratch and its the same there.

Question is, is that behavior wanted and clients have to stay in discovery list forever?

I’m having the same problem in reverse. We have 1 physical 17 VLAN.
I think my problem is caused by the DNS server.
I will change the DNS server at an appropriate time.
I think you may have a Route or DNS problem. Test access with tracert.

In this case it has to be in the behavior list

Thanks for your reply. DNS and routing are non of my problems as you can see here:

traceroute mx01

1 fw1 ( 0.221 ms 0.201 ms 0.187 ms
2 mx01 ( 0.556 ms 0.543 ms 0.531 ms

Can you check firewall access or try adding a full access rule on an IP basis.
Client or server may have access restrictions to each other. So one shows yes and the other shows no.

I already tried it with no difference. And it’s the same client. How can it show yes in client list and no in discovery list and also never disappear from discovery list? Also as long as the client is in discovery list as well its doing backups.

The client access above allows the client to access the server.
Access in the behavior list indicates the server’s access to the client
That’s why one party’s communication may be problematic.
Can you try to confirm that Windows network settings are not Public Network?

Thats both linux, client and server.

And as long as long as the client is in discovery list, there is no communication problem. Its doing backups and behaving like every other client within the same network as the server. Thats the weird thing. And the moment I delete it from the discovery list, communication to the client stops. Sounds to me like a bug. Unfortunately I dont have the skills to fix that problem, even the software is open source.

If you have the opportunity to add a different computer to the system for trial purposes, I suggest you try it.
You should try using the same version software as much as possible.
Then, by trying different versions, you can find out whether the problem is caused by the software or the network.

I checked a different client, same software version and could reproduce the behavior. I tried a different client version and still have the same behavior. SInce the backups are working as long as the client is in the discovery list, I doubt a network problem. My network isnt acting different when a client on the backup server is in a discovery list or not. For now I accept its just working as long as the client is in the discovery list. Maybe a future version of the server software is fixing the problem or uroni is having an idea what the problem could be.Thanks anyway for the suggestions. Appreciate it.