WEB interface SSL on CentOS

Hello, so as topic says, I`m trying to configure SSL for UrBackup web interface, but struggling doing so.
What already have done:

  1. Created Virtual Host:

<VirtualHost *:443>
ServerName some.domain
ServerAlias www.some.domain
DocumentRoot /var/www/urbackup
<Directory /var/www/urbackup>
Options -Indexes +FollowSymLinks
AllowOverride All

  1. Added symlink

ln -s /usr/share/urbackup/www /var/www/urbackup

  1. enabled virtualhost
  2. restarted httpd but when trying to open my domain with https I am getting apache demo page with Welcome page
    What I`m doing wrong?

Anyone please?

The urbackp server needs to be reverse proxied from apache as it is listening to port 55413

I access urbackup as https://server.name.local/urbackup/ so my configuration will differ from yours but the proxy section should be similar. My apache.conf structure is debian style but an important section of my configuration is:

/etc/apache2/conf-enabled/urbackup.conf

# UrBackup configuration file for apache 2.4 or later
<IfModule mod_alias.c>
  Alias /urbackup /usr/share/urbackup/www
</IfModule>

<Directory "/usr/share/urbackup/www">
  <IfModule mod_authz_host.c>
    Require local
    Require ip 192.168.0.0/24
    # Replace the range above with your subnet range and add
    # other ranges required. I don't make the site available globally.
  </IfModule>
</Directory>

<IfModule mod_proxy_fcgi.c>
  ProxyPass "/urbackup/x" "fcgi://127.0.0.1:55413"
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

This needs mod_alias, mod_authz_host and mod_proxy_fcgi enabled.

Or if you just want to get rid of welcome page, check welcome.conf in your apache configuration directory!
To make urbackup accessible, you still need to configure your proxy, to access to the urbackup, according to documentation! https://www.urbackup.org/administration_manual.html, 4.2 Make webinterface accessible via SSL

Ok, so because I have messed appache configuration at first I was still getting that welcome page, so removed apache, as I need it only for this proxy thing and reinstalled it, created file with your suggested configuration

/etc/httpd/conf.d/urbackup.conf

And now I`m getting error on the browser:

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

But actually if I open it with default :55413 port it works, any ideas?

I don’t remember the details of getting my setup going but I believe I based it all on 4.2.1 Apache configuration in the administration manual for UrBackup.

I assume that is a general “I can’t connect to the proxied service” message from Apache so the problem will be some detail of the cgi reverse proxy installation. There may be more clues available in Apache logs.

You will need the required Apache modules correctly installed with their prerequisites which caused me some confusion finding which Debian packages were needed. I can’t help with the CentOS setup steps required for a valid Apache cgi reverse proxy.