Web Interface Format Issue

I am having a strange issue with the date/time format in the Status page on the Web UI.
When I am logged in as the main administrator user (user rights: ALL) the format in Web UI is correct.
But when I create additional users with less rights or limited access the date and time format in the status page is displaying with a strange format…

For example: when logged in as this user with lower access roles, the status field is showing “1553263308” instead of the normal Never or other type message.
The “Last File Backup” is displaying “1553227179” instead of the normal month-day-year format, etc.

Again logging out and back in as the main user with “ALL” security rights, the exact same fields show in proper date/time format.

Is there any way to correct this format issue to proper format for the lower access users?

Not sure about the admin vs non-admin thing but I had a similar problem with all users after upgrading. Ultimately, clearing the browser cache fixed things.

cleared cache still same issue
also i tried from different pcs and still same issue
is this perhaps a bug or is there something I can do to fix date and time?
any manual config files i can perhaps manually set for this user?

can you try to change the language at the very bottom of the webui?

I changed languages but issue remains same.
the language changes but the Date-Time format issue is still same strange numbers.
Also I also noticed another issue with the users that are not Full administrators. All the Hyper-V clients the ones that are created from the Hyper-V VM names that appear in brackets do not show in the non administrator users even though I have assigned these specific Clients to the user/group.
Is there any way to get this to work ?

I was able to fix the issue of the Hyper-V clients not showing in the non administrator users. I had the wrong client ID assigned to them. So that is now working.
But the original issue where the Date-Time is showing as a series or strange Numbers and not in proper date and time format still persists for non administrator users.
Can you test this on your own and you will see same issue.
I installed a brand new urbackup on different server and had same bug. Can you perhaps issue a bug fix to this issue or provide some manual fix to correct the Date -time bug for the secondary non Administrator users?

I dodnt know you d need to give more settings and check with uroni , maybe some screenshots would help , maybe also screenshots and double check the language for urbackup and your browser.
I guess that what you see is a timestamp (seconds since 1970)

It is probably a browser issue. Can you tell us what browser you are using? Also, perhaps there are details in the browser console (CTRL+SHIFT+I in most browsers).

hi uroni
all is working good so far with new updated client you released for hyper-v. the exclusion has resolved the duplicate issue I was experiencing.
one issue that still remains is the web interface format issue. When I login as the default admin user the formatting is good.
But when I login as a non-admin user then the format is off. The fields for “Last Image Backup” and “File backup status” in Status page show as a strange number format instead.

please see this screenshot

it shows the strange formatting issue in status page

Again this is only happening for non-admin users

Its not related to any browsers because I tested it on 3 different browsers and all have exact same issue. These browsers also all work as the Admin user. I also tried different languages and it made no difference.

Please check it and see if this can be resolved as a patch

thanks again for your help

is there any update on this ?