WARNING: Filename "C:" contains ':' which the operating system does not allow in paths. Replacing ':' with '_' and appending hash

I get this warning in my logs every single evening.

These are my exclusions:
D:#TEMP*;D:\VirtualPCs*;C:\Windows*;C:\Program Files\WindowsApps*;C:\Users\victo\AppData\Local\Packages\TeamCherry.HollowKnightPC_y4jvztpgccj42*

These are my directories to backup:

Any ideas?

I’m running Windows 10 and only backing up the local PC.

1 Like

I have the same issue. In my case I am backuing up a linux mail server (Unbuntu 18.04) with postfix and dovecot. The serversoftware stores most of the mail datafiles with a ‘:’ in the filename.
Excluding the files is not an option.
The status mail from urbackup contains thousands of those warnings.
Do I have a chance to supress those kinds of warnings? As far as I have seen, urbackup handles backups and restores correctly (filnames are changed back upon restore, which is fine !)
Do I have a chance to modify the backup log before it is sent out via email?
I am running urbackup UrBackup Server 2.4.12 Rev. 487a3c7747 on Microsoft Windows 10 Pro (build 18363), 64-Bit.

Any help would be greatly appreciated.

Yeah, Logs -> Edit report script , then change the code to not count + add the warning.

Thank you for the quick reply !

Two last questions:
Where is the original script stored? Is in the database or on the filesystem? - I want to make a backup copy before I change anything.
In which language is it written?

Thanks again !!

I’d rather see a method for correction said warnings rather than simply suppressing them…

Unfortunately for any client where they’ve occurred I can’t seem to find one, even changing all settings to identical to a client where they don’t occur… well at least, short of deleting the client (and consequently all existing backups) & starting over from scratch… which seems a bit extreme to simply stop a cosmetic warning from occurring.