Vm spin up problems


We’re currently using the infscape appliance, and we’ve run two issues with the ‘VM’ tab and spinning up full images to a VM within the appliance. When we attempt to do it - these are the problems that occur:

  1. Sometimes the full image backup doesn’t even show up as an option to spin a up a VM from ( it’s a just grayed out box ).
  2. On a VPS, the appliance will actually crash and need a reboot, or the appliance web front end will crash and the page will need to be refreshed
  3. On a Bare Metal device, we are able to actually get a VM configured ( unless problem 1 happens and we can’t select an image ) but we’re unable to start the VM because the web front end crashes.

Things we’ve tried:

  1. We’ve tried a VPS
  2. We’ve tried the infscape appliance on a bare metal with virtualization enabled since we considered nested virt to be a possible issue.
  3. We’ve cycled through all the various networking options ( bridged, nat, host, and none ).
  4. At one point we thought that the image size ( 256GB ) may be a problem, so I did a full image of a 50GB virtual machine but then problem # 1 occurred and we couldn’t select it as an image to spin up a VM from

Anyway, we’re really interested in getting this feature to work.

Please let me know if anyone can assist.

Thank you :slight_smile:

Sorry you are having problems.

Did a quick test with a new appliance on DigitalOcean and a Win10 client and it (unfortunately) worked without problems. It even seems to have nested virtualization enabled, though it automatically falls back to really slow qemu emulation if that is missing. Bridged networking obviously won’t work, though (it needs e.g. promiscuous mode enabled or bare metal).

So could perhaps describe more details w.r.t. the VM to allow reproduction of the problem. For instance:

  • If the disk is MBR or GPT formatted
  • If it boots via UEFI or not
  • Exactly what kind of OS is on the disk
  • The disk partition layout (ESP, SYSVOL, C, other volume?)
  • If the web interface “crashes” does it show any error messages?

Other than that if you use the “Report problem” link on the bottom of the appliance web interface you can upload the appliance logs. Those might be helpful. And if you want to send me SSH connection details to a (test) appliance that exibits the problem(s) that would nearly guarantee that the problem(s) can be pinned down.

Thanks for the reply. Here are the answers to your questions:

• If the disk is MBR or GPT formatted: GPT
• If it boots via UEFI or not : Yes it does.
• Exactly what kind of OS is on the disk: Windows 10 Home

• The disk partition layout (ESP, SYSVOL, C, other volume?): Yes, this is the precise layout. In the ‘Create a new VM tab’, these volumes show up in this order:

Volume 1 → SYSVOL
Volume 2 → ESP
Volume 3 → No Image backups
Volume 4 → C

• If the web interface “crashes” does it show any error messages?
Yes it does and it occurs when attempting to start a VM. I’ve redacted the IP.

SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

I’ve submitted a ticket as well - #146. I wouldn’t mind giving access via ssh, but I have no idea what the root password is since my attempts at elevation through the shell with the admin pass have failed.

sudo -i should work. Loggin into the web shell at Settings → System → Access server web shell should also work.

I had a look at the log files and this seems to be the problem:

ERROR internal error: process exited while connecting to monitor: 2020-10-12T16:26:09.936553Z qemu-system-x86_64: Property ‘.intel-pt’ not found

At this point I’m inclined to believe that qemu needs an update to some newer version.

Yep, sudo -i did work. I was attempting to elevate through a second admin user which isn’t in the sudoers file.

I ended up checking a few things:

  • intel_pt and VT-X is enabled in the kernel
  • I am running qemu version 2.8.1 ( 1:2.8+dfsg-6+deb9u11 , which is newest version in the oldstable/updates repo for stretch.

Any recommendations? Is there a way to disable intel-pt support, or would that have adverse affects on the VM?

I also don’t mind providing ssh access to you to look at first hand.

First thing I’d try is changing to buster in /etc/apt/sources.list then update qemu (apt install qemu-system-x86). After that (and a reboot) it had a problem accessing /dev/kvm which I fixed via chmod 777 /dev/kvm

Awesome. That worked. I’m running 1:3.1+dfsg-8+deb10u8 now.

I’m able to remote desktop into it, but once the Windows loading screen finished. I get an ‘The PC ran into a problem’ with INACCESSIBLE_BOOT_DEVICE as the error. I’ve seen others report this as well on the urbackup solution… I’m assuming this has to do with the system running on different hardware?

Any solutions?

Thank you so much.

Actually… ignore the above. I was using a VM config pre-upgrade of qemu. I’ve recreated the VM, and it works now. I’ll mess around with it some more, but this is very cool.

One final thing regarding:
Sometimes the full image backup doesn’t even show up as an option to spin a up a VM from ( it’s a just grayed out box ).

I had imaged a second device, and it didn’t show up as an image selection option under the VMs tab.