Use/decompress VHDZ to VHDX

I was going to use a backup to dig out some data as my system had to be rebooted and that installation didn’t work. When I got to the backup files via the Samba share in TrueNas Scale, I noticed that they ended in “.VHDZ”. Looking for a simple solution, I ended up installing the server version of UrBackup on an external medium under Windows and using the “uncompress_image.bat” file from there, I tried to decompress the original file. At the end it said it was complete but it didn’t change the file (it’s only 128GB now, which should be correct for the content). I’ve also seen posts here (“Uncompressing vhdz images - #2 by uroni”) where there seem to be solutions, but don’t understand them as it addresses files that I apparently don’t have.

Now the .bat script just says "
2022-12-05 19:51:38: VHD-Parent: “\TRUENAS\backups\DESKTOP-John-ITX-PC/221103-0813_Image_C/Image_C_221103-0813.vhdz”
2022-12-05 19:51:39: ERROR: Magic in header not found for compressed file
2022-12-05 19:51:39: WARNING: File is not compressed. No need to decompress.
Drücken Sie eine beliebige Taste . . ."

I need help, because otherwise a lot of private and personally important data will be lost

Do you have other meta files related to the vhdz? Mine is as below and no problem decompressing.


Maybe try renaming the vhdz to vhd and try opening with windows? It should be able to mount the vhd file.

Thanks for your answer. I can rename the file and it is recognized as a VHD. However, when I select “Mount as ImDisk Virtual Disk” it is not recognized correctly and is supposed to be formatted. That brings me very little if I want to get the content out.

And yes, I have these meta files.
Image befor meltdown

I also tested a backup, from a working point in time, but I get the same problem when I rename it “.vhd”. It mounts and asks to format it.

How about if you try backup using VHD (uncompressed)? Would you be able to mount that image?

Also, are there any error in the backup logs?

I tried to mount it using “Mount as ImDisk Virtual Disk” and it gave the error that it needed to be formatted. I’ll try later to install it via UrBackup, but unfortunately, even if it works, my new mainboard can’t recognize this Windows installation as boot medium. That’s why I also wanted to go to the backup without setting it up because I had to set up my Windows again.