UrServer Backup Schedule


I have a small question, UrBackup is working remarkably well, but i’ve noticed that my backups are not completing on time.

For this setup I have 22 active clients connected to a CentoOS UrBackup Server (server is 2.2.11). I’ve set the server to make file backups every 48 hours (incr.) and every 14 days for a full backup. The image backups are set to make a new incremental every 1 day, full every 7 days. The server is also set to allow 3 simultaneous backups. The interval for incremental and full backups are set to 1-7/0-24 (aka every hour of every day of the week).

How the file backups are not really relevant, they copy nothing or very little as i’m mostly interested in the image backups.

However i notice that even though it does make some backups, mostly at night, but it hardly backups anything during the day and not nearly everything during the night. This results in at least half the clients are not backed-up and after a few days are running hopelessly behind. I can manually start the image backups, full or incremental without issue, the backups also progress normally. It’s just the scheduled backups that are not running as expected.

Perhaps smart to note that i did have a schedule that backups could only run between 18:00 and 06:00 hours. But this has long since changed.

Is there anyway to troubleshoot this?


Alright, i’ve tried updating clients, restarting clients and server but the result is the same unfortunally.

Perhaps another question. Manually starting a backup from the website just involves a website from giving the right commands to the back end to start a backup and keep track of the backup. I was wondering if it’s also possible to start a backup from command line on the server (Linux)? Say some kind of command to urbackupsvr to start a full/incremental image backup for client X? If the website can do it, you should also be able to do it from a SSH prompt as well?

If possible, does anyone know of such commands? I know the urbackupsvr executable has several command line arguments you can parse to it, although i’ve been unable to find a complete list.


You could use e.g. this: https://github.com/uroni/urbackup-server-python-web-api-wrapper


From the client where you want to make the backup you can use urbackupclientctl run with --help to see how it works.
So urbackupclientctl + ssh


Thanks Uroni and orogor :slight_smile:

I’ve been working with the API now, very powerfull and usefull. The documentation on it seems a bit, well absent. But the examples are usefull and though those and some trial and error i’ve been making real progress. I was wondering two things though:

  1. Does the UrBackup server keep track of a queue (as in max image backups is 2 in my case, but I can start multiple backups, they do seem to be queued in the website). And if there is a queue, how could i access it though the API? There doesn’t seem to be a function to handle that (yet). If anyone could point me to the right parameter to dump in :

self._get_json(“getqueue”) or something, i’ll figure the rest out myself :slight_smile:

  1. The urbackup_api you download with the : pip3 install urbackup-server-web-api-wrapper command doesn’t seem to be up to date. The version I got seemed older then the source code on github, for example the pip3 installed one is missing the get_actions attibute. you can easially replace the downloaded one with the one on github, but just thought i’d point it out.


Ok, I still haven’t found a way to access the queue (i’m more of a scripter then a programmer, so the c++ source code is a bit hard to follow), and i’d still like to know if we can access the queue somehow.

However I have created a python script that does everything I need. Instead of checking the queue i’m simply checking if the maximum simultaneous amount of backups are not already running, and if not, then check if any clients image backups are older then 32 hours, then if the backups are not running already, start a full or incremental backup, depending on how old the last full backup of this client is.

The code is a bit messy and not everything is run from the parameters in the server itself (some are hardcoded) so i’ll need to clean it up before sharing, but if anyone wants in the mean time, just let me know and i’ll post it somewhere.


I think I finally may have figured out the root cause why I wanted to create this script in the fist place!

The clients that are not backing up according to the schedule in the UrBackup Server are Internet Clients. Most of my networks are hooked up through different VLAN’s with different IP ranges, hence most things connect as Internet clients.

I just noticed that a internetclient I upgraded to a CBT client wasn’t being backed up on schedule and more importantly since the upgrade, only the C drive was being backed up! I checked the local client settings, and there it is… All settings under the image back-ups tab was set to the default UrBackup Client settings, not the settings it should have had from what I set in the server!

Interval for backups was 7 days instead of 1 day, and only set to backup volume C, and not all of them (D, E and F).

I thought the clients got there configuration from the server, is that not true for internet clients?


Do you have “Allow client to change settings” set?


Hi Uroni, Yes it is.


If you don’t change settings on the client, disable that.


I do configure the server components on the client as well as the file paths, but I assume those options are unaffected by the Allow client to change settings option. I’ll try that, thanks sir.


Unfortunally, chaning this setting did fix my issue, but caused another one, the component backup settings are reset to server default, which are default=1 (aka DO component backups). I’ve created seperate client configs on the server and set the component backups to default=0 for the servers i really don’t want this to happen on.

This is probably done by design, but just a heads up for other people reading this, if you uncheck the Allow client to change settings checkbox, no matter what “the allow users to configure components to backup” checkbox is set to, and what you set this to on the client, it will be overwritten by the default setting on the server under Settings -> General -> Advanced -> Windows components backup configuration. settings this to default=0 backs nothing up, default=1 enables the default file backup of windows components (such as SQL).