URGENT (Visual Studios 2010sp1)

Ive recently tried to install UrBackup but i get an error message saying

Ive installed it onto multiple pc’s they all dont have Visual Studios but one computer was successful with installing the program and beginning the backup. I just dont see why its necessary Any feedback is appreciated

No idea why you are getting that error, as I have not tried 1.4.9 just yet. But, you should be able to install that runtime yourself and then complete installation. My guess would be that there is a GPO or some other restriction preventing you from installing said runtime.

What OS version are you attempting installation on to?

It is just a runtime. Every program compiled using Visual Studio will have a runtime environment associated with it. VS2010 C++ runtime is similar in effect to the .Net runtimes that you likely have many of installed on your computer. Similar concept.

I think where you are getting confused is that you think you need Visual Studio itself to be installed on the computer. You do not. Only the runtime.

Install it manually from here:

http://www.microsoft.com/en-us/download/details.aspx?id=8328 for the x86 version

http://www.microsoft.com/en-us/download/details.aspx?id=13523 for x64

The installed checks if the appropriate runtime is installed and then attempts to install it if it is not. Could you try a manual installation of the runtime and report back if you run in to problems with that?

1 Like


I know this was end of last year, but I am having the same problem installing on a 2012R2 server. I get the same error message exactly, and I have tried (1) installing the runtime you specified above (64bit) and also (2) going to the temp location in the error message and installing the vcredist_2010… etc version. I have also restarted afterwards, but the install continues to stop at this point. I am trying to install the 1.4.11 client.

Any help would be greatly appreciated!

Also, the runtime installs fine. No error message or anything. Says it installed successfully at the end. But the client install doesn’t seem to recognize that this has been done.

Which server version are you trying to install?

The server version is 1.4.14 and is successfully installed on another server which has the data repo internal. I have also successfully installed the client version 1.4.11 on three 2012 servers and two 2008 servers with no problem. They are backing up just fine. It is just these two domain controllers running 2012 that are giving me exactly the same issue!

Have you checked in Add/Remove Programs to see if the runtime is installed?

Could you run the vcredist installer in an admin cmd and post the output?

start /wait vcredist_2010sp1_x64.exe /q /norestart

As a work around I guess you could use the MSI installer.

Well, it appears it is already installed. The commands you provided ran very quickly and return 0. Then I checked Event Viewer for more information.

Figure 1: Administrator elevated command prompt

Figure 2: Event viewer

Figure 3: Event viewer

Figure 4: Program listing shows already installed

Figure 5: UrBackup client install still reports it is missing

Well, the installer does not show the message box if it returns zero so something else must be going on…

Maybe you should try with the MSI installer ? It doesn’t contains the Visual Studio verification step i think …


1 Like

Sorry I have no longer need any info on it as to I could not get an answer or figure it out during the time of need. I resorted to Zoolz which is a great product and a resonably priced option. Sorry I couldnt be much of help. Where were you guys when I needed you haha. Cheers and hope you find out the issue because im still curious. Still use UrBackup at multiple clients of mine.:grin:

I literally replied with a possible solution 18 hours after you posted your issue. :stuck_out_tongue:

1 Like

Awesome! You are right–it doesn’t contain the Visual Studio verification step!! The install went straight through without an issue. Thanks!! With the fact this great software is open source and developers and support don’t get paid–you guys do have a great response time even when I chain my issue to this older post! Thanks a million!