UrBackup setup with network drives, not working

Hi Urbackup Community,

I’m trying to implement Urbackup as my primary backup system for all clients.

No issues here, just installing client on host and then backing up with web server.

Some clients though use CTERA Cloud Backup, it’s basically a CTERA NAS backing up directly to the Ctera Cloud.

Since I can’t install UrBackup directly on the NAS, I tried to perform the work on it mapping it as Network Drive, giving me those errors.

I tried every guide on VSS error, vssadmins are ok, shadow copy is enabled as service, cleared all old shadow copies.

Mind that I installed the client on a Windows server 2019 with the NAS mapped as a network drive.

If anyone has a suggestion, I would be really grateful.

Thanks for your attention
errore vss vergati

Do you mean, you are using urbackup on a machine that has the data mounted from NAS using SMB like \\server\share? Vss is not supported on mounted SMB shares, and Urbackup will complain about it but should do the backup nevertheless.

Yes, exactly.
Thing is, it won’t do the backup, goes for indexing, after indexing completed the client goes idle, missing the backup.

Check for your includes and excludes. Perhaps just none of your files correspond to backup criteria.

I am doing file backup from UNC paths from several servers successfully.

What do you mean by backup criteria?
Those are normal files, excels, pdfs.
I put UNC paths both in includes and backup paths.
Still gives me the same error, goes directly to idle.
This time I also manually worked on windows search indexing, made sure it was working as service, cleared up old installations on the client and folders on web server.
Started anew, but still nothing.
Do you think maybe it’s because my type of NAS is not supported?
It’s a CTERA, not a NAS Synology

You shouldn’t put backup path in includes. Rather leave it empty to backup everything.

Includes is a pattern against which files are matched. If you put the path there, it matches only the path itself, not the files it contains.

Check (https://www.urbackup.org/faq.html) How to include files?

NAS “support” is not relevant. If your workstation that does the backups can read the files, it can backup them.

It’s working!!
Nice, thanks to your suggestions, I removed some paths and includes, then I checked the log in debugging mode, removed encrypted transfer via internet, it’s doing its job.
Only thing, seems like it’s capped at 1mbit per second, is there a maximum bitrate cap?

Worked out the speed limit too, have a great weekend everyone!

Please share, “Worked out the speed limit too”


On the UrBackup server there are several settings for clients, many of those are about speed limit.
Just don’t leave them blank, fill them with the speed you like, for example i put 200000 kbps on the backup internet speed section.
After that you can check the speed in the activity tab.
Only thing, after the “files has been transferred” my backup fails and there’s no files on my webserver…