Urbackup Server on ARM64 CPU architecture


I need your help. Last week I bought a new Odroid N2 (something like Raspberry). With this Mini PC, it’s not possible to install urbackup Server, because the CPU architecture ARM64 is not supportet. On web I only found installer for armhf, amd64 etc. but nothing for arm64. Do you know how I could install it on my „server“? Or is it in work to develop an installer for arm64? I’m not a Linux expert, so maybe it’s easy, but I don’t know how I could get this great software running.

Systemenvironment is an Ubuntu 18.04

You can install from source: https://www.urbackup.org/server_source_install.html Use ./configure --enable-embedded-cryptopp to make it easier (no need to install crypto++ dependency). Install build tools beforehand (apt install build-essential)

1 Like

Thank you, I will try it and tell you, if it was successful

I tried to install urbackup with the source download.
Install ( apt install build-essential) worked. ./configure --enable-embedded-cryptopp worked well, no errors.

But after the command “make”, there are a lot of warnings, like them:

urbackupserver/ServerDownloadThread.cpp: In member function ‘bool ServerDownloadThread::logScriptOutput(std::__cxx11::string, const {anonymous}::SQueueItem&, std::__cxx11::string&, int64, bool&)’:
urbackupserver/ServerDownloadThread.cpp:1787:15: warning: ‘template class std::auto_ptr’ is deprecated [-Wdeprecated-declarations]
std::auto_ptr touch_file(Server->openFile(os_file_prefix(backuppath + os_path), MODE_WRITE));
In file included from /usr/include/c++/7/memory:80:0,
from ./cryptoplugin/src/stdcpp.h:15,
from ./cryptoplugin/src/cryptlib.h:103,
from ./cryptoplugin/src/iterhash.h:6,
from ./cryptoplugin/src/md5.h:4,
from urbackupserver/…/urbackupcommon/fileclient/…/…/md5.h:124,
from urbackupserver/…/urbackupcommon/fileclient/FileClientChunked.h:7,
from urbackupserver/ServerDownloadThread.h:15,
from urbackupserver/ServerDownloadThread.cpp:22:
/usr/include/c++/7/bits/unique_ptr.h:51:28: note: declared here
template class auto_ptr;

Should I ignore them? After more a hour, its not even finished, so I could not execute “make install” yet.

Have you got a tipp for me?

Generally as an end user, it’s fine to ignore warnings.
And compiling on cheap (or even expensive) SBC systems is always slow. The CPUs aren’t great at compiling code, plus the onboard flash storage is often relatively slow making it even worse.

It is possible to compile the ARM64 version on a proper desktop x86 based PC. This is called cross-compiling. However it can be complicated and I would recommend just being patient with the slow compile if you’re not confident with Linux at this stage.

Thanks for your answer. With make -j 4 it was much faster, so it works now.