Urbackup on Synology

Good evening,
I want to ask whether is possible to install UrBackup 2.0.x on Synology with CPU MARVELL Kirkwood 88F6281. I found version 1.4.13 on Daniel Tofee web page but the new version is unfortunately not there. Thank you for your wondreful software!

I was succesful at the end
simplyfied steps:

  1. install Debian Chroot to DMS ( https://synocommunity.com/#easy-install )
  2. download source codes of urbackup 2.1
  3. switch to Debian Chroot
  4. unistall systemd and install sysV ( http://without-systemd.org/wiki/index.php/How_to_remove_systemd_from_a_Debian_jessie/sid_installation )
  5. finish instalation of the packages for compilation (crypto++, gcc, etc)
  6. compile urbackup
  7. use init script from different server :slight_smile:
  8. set startup after the start of synology chroot and init script

Hmm http://packages.synocommunity.com is not available (400 bad request).

With a more modern CPU the ARMv7+ debian package on the download page should work…

I have edited step one.
I have tried instalation from the compiled package but it failed (wrong CPU).

Yeah, your CPU in the first post is a ARMv5 CPU. Those are really old…

Yes I know. I have tried the instalation even for Synology with CPU Intel Atom and there was possible to use a compiled package.
Would it be hard for You to prepare the compiled package for ARMv5, too?
Thanks a lot for Your perfect software anyway!

That way we could run UrBackup on a Palm :wink:

I followed your steps and with small adjustments works as it should, but …, of course always exist a but, when I want to transfer my old server database from ubuntu I get “segmentation fault” error and the urbackup process dye. Is working flawless with the fresh database. Is anybody who have more experience with this?

Web gui (ip_address:55414) stopped working after I upgraded to version 2.1.19. Any suggestion? Backup still works. Thank you!

If anybody is interested in it. I also managed to get the urackup client running on a synlogy NAS.
Here are the steps:

  1. add new package source: https://synocommunity.com/#easy-install
  2. install community/debian chroot
  3. open ssh connection to nas
  4. vi /var/packages/debian-chroot/scripts/start-stop-status
  5. add line after other mounts (assuming you want to backup volume 1):

grep -q "${CHROOTTARGET}/mnt/volume1 " /proc/mounts || mount -o bind /volume1 ${CHROOTTARGET}/mnt/volume1

  1. add line after other umounts

umount ${CHROOTTARGET}/mnt/volume1

  1. add to /etc/rc.local

chroot /volume1/@appstore/debian-chroot/var/chroottarget /usr/local/sbin/urbackupclientbackend -d

  1. /var/packages/debian-chroot/scripts/start-stop-status chroot
  2. apt-get update && apt-get upgrade
  3. apt-get install locales
  4. dpkg-reconfigure locales
  5. choose en-us-utf8
  6. install urbackup client from script (see https://www.urbackup.org/download.html#linux_all_binary)
  7. in urbackup server gui add new remote client and copy config string and execute on shell (still inside of the chroot)
  8. urbackupclientctl add-backupdir -d /mnt/volume1

You should be done :slight_smile:
I didn’t try out if the client would work outside of the chroot. maybe it would…

How to run urbackup server inside of chroot ?

You should be fine with a 2.1.20 build of the server. Mind I have not tried it yet , I am running a patched 2.1.19.

The issue is an infinite loop when the server runs on armv5 (no support for accept4) https://github.com/uroni/urbackup_backend/commit/eb4e5ed2a13559ca390a175c438702415ddea6df .

If you want to stick to 2.1.19 you also need https://github.com/uroni/urbackup_backend/commit/3536af43eeee847fb1b5f012fe978604ccebce23. Cheers