Urbackup_mount_helper test : Backupfolder not set


The gui doesn’t show the mount option when browsing vhd/vhdz
The service run inside a docker
UrBackup Server v2.2.11.2193

when browsing the vhd, a single line appear :slight_smile:
VHD-Parent: “/var/docker/data/urbackup-server/datas/urb-client/180403-1246_Image_C/Image_C_180403-1246.vhd”

fuse module has been loaded and urbackup restarted

os is archlinux so the packages depends on fuse and is compilled with -with-mountvh

/usr/sbin/urbackup_mount_helper is setuid

urbackupsrv mount-vhd --file /var/docker/data/urbackup-server/datas/urb-client/180403-1246_Image_C/Image_C_180403-1246.vhd --mountpoint /mnt/tmp/
Loading FUSE kernel module…
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.15.15-1-ARCH
Starting VHD background process…
Waiting for background process to become available…

during that times dmesga and journalctl shows nothing special

ls -l /lib/modules/4.15.15-1-ARCH

ls: impossible d’accéder à ‘/lib/modules/4.15.15-1-ARCH’: nu such file or folder

lsmod | grep fuse
fuse 118784 1

i installed libguestfs (should i ask to add that dependency in the archlinux package ? )
libguestfs-test-tool finished with ===== TEST FINISHED OK =====

/var/log/urbackup-fuse.log contains
2018-04-20 12:27:50: Mounting VHD via fuse…
2018-04-20 12:27:50: Volume offset is 524288 bytes. Configure via --offset
2018-04-20 12:27:50: ERROR: Error mounting fuse filesystem

I’m not sure mounting file system works within docker containers. Let alone then creating loopback devices and virtual machines etc. for guestmount.

You can probably give the docker container all capabilities and map the host /dev sysfs into the container, but then the container becomes a bit useless.

ok , that works in commandlie by setting full access to host in docker.

But in the gui the button isn t showing up

I think you have system installed on non btrfs filesystem, where urbackup tmp is set by default.
Move your tmp folder to btrfs partition and button will show after restarting the service.

check /etc/sysconfig/urbackup-server