UrBackup configuratión

How can I do to configure a backup to save only one fullbackup and incremental it in case of they are changes in a files?

In the original repository size is 500 Gb, but on the UrBackup server disk occupies more than doubled.

Regards, Benja.

Change these numbers in webinterface accordingly, either server-wide or per-client. Plus, keep in mind that you don’t necessarily need ALL your files, you can specify which ones to backup.

Can’t vouch for image backups but should be similar.

Maximal number of full file backups = 1
Minimal number of full file backups = 1
Minimal number of incremental file backups = 0


You will probably need at least 1 on incremental if you plan to do it manually, otherwise you would be turning it off completely. Can you explain in more detail what are you trying to do? Only run full file backups? This will eat a lot of space either way, but yes, if you drop it to 1 backup it will take at maximum that amount.

I tried to configure UrBackup to only save one copy of original and another copies if they are changes. Now, it is saving multiple copies unchanged.

Did you restart the server? Well, more importantly, if server recognizes that you changed the settings, you just need to run cleanup, which requires server to be down. Can you try that?

In my case not is possible to restart the server, but the cleaning window this set for daily run

I don’t mean the physical server, just the UrBackup server, or rather service, if that is of any help :slight_smile:

I have configured the cleaning window to execute daily, but the option to automatically shut down server is disabled. This is the option to restart only the UrBackup services?

I attached pictures of the current configuration.

You don’t need that setting, as that shut downs the machine (you’ll find this in the manual).
Now, depending on how much you are familiar with CLI, what you have to do is stop the service, run cleanup, and then start the service.

Code to be launched from terminal:

(now, to kill urbackupsrv you’ll probably need to find its PID and use that, as there is no stop function for it)

kill %PID of UrBackup%
urbackupsrv remove-unknown
urbackupsrv run --daemon

Ok, thanks.