UrBackup Client and Server in the same machine, but with symbolic link folder?


#1

Hello,
I have UrBackup server installed on my Debian based NAS, but I moved the UrBackup server database folder to another location and then make a symbolic link to it and it works corectly with no problems.

Now I want to install UrBackup Client in the same machine, but apparently it not install correctly, it not creates all configuration files inside the urbackup folder (I suppose thant the server and the client shares the same folder?).

Is there any workarround to have server folder linked and run client from here too?
I need to install both (client and server) before make the symbolic link?

Thank you so much.


#2

Well, I have removed the symbolic link and installed it in the default folder, so I have server an client running together. But, the server does not recognize client, the server interface shows the message : " This server has discovered clients which are currently not configured to use this server…"

And also when run the command urbackupclientbackend -v info

2018-10-09 13:52:29: ERROR: urbackupserver: Failed binding socket to port 35623. Another instance of this application may already be active and bound to this port.
2018-10-09 13:52:29: ERROR: Binding tcp socket to port 35621 failed. Another instance of this application may already be active and bound to this port.
2018-10-09 13:52:29: ERROR: FileServ exit with error code: 99
2018-10-09 13:52:34: Started UrBackupClient Backend…
2018-10-09 13:52:35: Looking for old Sessions… 0 sessions


#3

Check in the client server_idents.txt if has the same key as the server_ident.pub in the server.
Is described at the top of the FAQ https://www.urbackup.org/faq.html


#4

Thank you. I found the problem… … the client was connected to other urbackup server in the same network.