Upgrading from 2.3.8 to 2.4.9 if you installed with Ubuntu packages

I installed urbackup server with these instructions:

sudo add-apt-repository ppa:uroni/urbackup
sudo apt update
sudo apt install urbackup-server

sudo apt update and sudo apt dist-upgrade are not taking it from 2.3.8 to 2.4.9. How do I update it?

It looks like it worked for me using these 3 lines…

not sure if it is relevant, but the first time I installed the package on my unbuntu, I was running a newer version of ubuntu which was not yet available on uroni’s site so I had to use alternate instructions to download the packages from opensuse which includes adding some key.
https://software.opensuse.org/download.html?project=home%3Auroni&package=urbackup-server

1 Like

I guess you need to tell us your ubuntu version. Maybe it is not supported anymore (or I forgot to specify it during packaging…)?

It’s Ubuntu 18.04. Maybe I need to run some command other than apt update and apt dist-upgrade to get it to version 2.4.9?

I originally installed version 2.3.8 and want to update. I figured it might just be a normal apt update and apt dist-upgrade but that doesn’t update it.

Anyone have an idea how to get this updated? If I do an apt-get remove urbackup will it keep all my config and backup files and then maybe just apt install urbackup-server?

Please read my responses previously to see where I’m at.

I’m running 19.04 but all I did was follow the link by @ffsb and then here are my exact commands used:

362 sudo apt update
363 sudo apt upgrade
364 sudo sh -c “echo ‘deb http://download.opensuse.org/repositories/home:/uroni/xUbuntu_19.04/ /’ > /etc/apt/sources.list.d/home:uroni.list”
365 wget -nv https://download.opensuse.org/repositories/home:uroni/xUbuntu_19.04/Release.key -O Release.key
366 sudo apt-key add - < Release.key
367 sudo apt-get update
368 sudo apt-get install urbackup-server

Worked a treat. Upgraded to the latest version from the beta version. Also all my clients (only 3) upgrade fine too.

But dude, backup backup backup. Before you do anything.

I don’t want to use opensuse links/repositories for ubuntu. It doesn’t make sense.

@uroni How can this problem be resolved? Should I try removing it but backing up certain directories first? It appears your repositories don’t update from 2.3.8 to 2.4.9. I’m sure a fresh install will work the same as it did with 2.3.8 but this should be upgradeable.

This is what I have for a repository.



cat /etc/apt/sources.list.d/uroni-ubuntu-urbackup-bionic.list 

deb http://ppa.launchpad.net/uroni/urbackup/ubuntu bionic main
# deb-src http://ppa.launchpad.net/uroni/urbackup/ubuntu bionic main