Upgrade to 2.4.13 on freenas


I have noticed the latest version for UrBackup is 2.4.13 however on FreeNAS when I follow the instructions I still only get 2.4.12

Is there a reason why the FreeNAS version has been kept back? Should I be attempting to build from source within the jail?

I tried doing a build to get to 2.4.13 but I could not recover a working backup solution. I reverted to 2.4.12 and lost all my backups. Fortunately no great deal for me.
After seeing your post I build a FreeBSD 12.2 jail in TrueNAS to test and it is still messy. I ran a repair-database as root and got the server up but as there were no backups it was not a true test.
Not sure if I will try this again on my “production” box.

Seems @kcoombs dropped the FreeBSD maintainership… someone needs to take over…

…or you can compile from sources in a jail yourself:

pkg install curl
./configure --enable-embedded-cryptopp --enable-embedded-zstd
make install


Neel Chauhan took over maintainership and updated it: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251516