Update to 2.5.29 ignores all configured excludes on the group level

I have most excludes on a group level and with the update to 2.5.29 suddenly the excludes configured on the group level were ignored (resulting in attempting to backup multiple TB of data previously excluded).

Changing around settings for a client and then switching back to the group setting somehow sometimes seem to restore it properly using the group’s excludes, but I have not yet found the minimum required steps to fix the issue. Currently it’s primarily trial/error.

EDIT: Not longer sure if it works at the group level at all, just noticed that all clients that work are on “Use settings configured here”, because I somehow clicked into the textbox, it seems.

Same here.

All my clients now ignore group excludes. After upgrade to 2.5.29 all new backups have folders that were successfully excluded in the last backup.

Also, it seems that “Default directories to backup” is not applied from group (discovered that by creating a new group for testing and configured a new client in that group and then changed the value). But that is less of a pressing issue at the moment.

P.S. where do you see “Use settings configured here”? I seem to be missing it altogether in this version, I remember seeing it previously.

I still have the possibility to switch between the different modes of configuration the “Home” is the “configured here”, the “Briefcase” is “configured on group”, the “Road” is “configured on client”, and the “Copy” icon is the “configure multiple”.

But at least excludes are only applied from “configured here” for me, not sure if this also affects other configurations.

Could be a wider problem with the group settings: Backup Options, Groups Not Following Setting(s) - #10 by Ajeris_Gspak

oh yea, these icons… quite cumbersome ux
forgot to hover for text

Seems to have been fixed, will try as soon as the docker image is available.

EDIT: Works for me now, thanks for the fast new release!

1 Like

Yes, works for me too. And also seems another UI bug i was whining for some time was fixed as well (“changed conf” asterisk in front of all my hosts). Awesome.