Unsupported .eh_frame_hdr version


#1

Hi there,

I run an Urbackup Server on a Windows 10 PC. It ist working very well with some Windows Clients.

Now I try to use the client on an raspberry pi 3.
The Installation as described here (the TF= … command) seemed to work.
The client is discovered by the server and the service is running.

Now, when I try to add a backup directory, the following message is displayed:
urbackupclientctl add-backupdir
Assertion failed: Unsupported .eh_frame_hdr version (…/…/src/c++/libunwind/src/EHHeaderParser.hpp: decodeEHHdr: 62)

The raspbian is up to date. I even reinstalled raspbian completely new

The Urbackup Client Versions that I tested are 2.1.15 and 2.1.16.
I also installed the linux client on a Windows 10 WSL Linux Shell. That works as expected.

can somebody please help with this error message?

bye,
Eurofalter


Client for Raspberry Pi
#2

It’s probably a toolchain issue (exceptions don’t work http://ellcc.org/bugzilla/show_bug.cgi?id=78 ). Try to enter the correct command and it should work.


#3

Getting the same error here on one of my raspberry pi’s I’m backing up …

All my other clients, including some other raspberrys, are backed up fine.

root@sel-pi-zerow01:~# urbackupclientctl start
Assertion failed: Unsupported .eh_frame_hdr version (../../src/c++/libunwind/src/EHHeaderParser.hpp: decodeEHHdr: 62)
Avbruten (SIGABRT)

Log says:
2018-07-02 20:42:26: ERROR: Error creating pthread. Errno: 12

Running version 2.2.6.0 on a Raspberry Pi Zero (Linux 4.14.34+ #1110 Mon Apr 16 14:51:42 BST 2018 armv6l GNU/Linux)


#4

Has this issue been resolved?
I just installed UrBackup on 2 of my pi’s and have this issue on both.
One is running raspbian and the other is retropi.
I cant seem to add any location no matter what i try, sudo or not.

Also, tried to do a urbackupclientctl set-settings and received the following error:
“urbackupclientctl: Permission denied
Cannot read backend password from /usr/local/var/urbackup/pw_change.txt”

any help would be greatly appreciated.
Thanks


#5

Any help with this would be great, I cannot backup y pi’s untili can get this resolved.


#6

This is only an issue with the error reporting. Call the command line interface correctly, or don’t use it and set up everything on the server web interface.

e.g. usually:

urbackupclientctl start
PARSE ERROR:
             Required arguments missing: image, file, full, incremental

Brief USAGE:
   urbackupclientctl start  {-i|-f} {-l|-m} [-c <hostname/IP>] [-p <path>]
                            [-b] [--] [--version] [-h]

For complete USAGE and HELP type:
   urbackupclientctl start --help

#7

Thank you so much.
That solved my issue.