Unable to restore image (disk too small)

When I try to restore an image using restore ISO 2.4.0 is always comes back with an error:

When using the previous restore ISO 2.3.1 it restores good.

I have multiple servers, 2.5.23 beta and 2.4.13, but both give the same result.

The restore target is an Debian 11 XEN project server. I’m restoring to an LVM volume.
After the error appears these partitions are on the LVM volume:
Command (m for help): p
Disk /dev/mapper/VG0-w2022dc1: 42 GiB, 45097156608 bytes, 88080384 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x77e35385

Device Boot Start End Sectors Size Id Type
/dev/mapper/VG0-w2022dc1-part1 * 2048 206847 204800 100M 7 HPFS/NTFS/exFAT
/dev/mapper/VG0-w2022dc1-part2 206848 88076287 87869440 41.9G 7 HPFS/NTFS/exFAT
/dev/mapper/VG0-w2022dc1-part3 250580992 251654143 1073152 524M 27 Hidden NTFS WinRE

So it looks like ur is trying to restore to the first partion? It clearly says: “Using partition 2”…

Thanks for the heads up! Does it work with the graphical restore?

I wasn’t aware of the graphical interface… :grinning:

I tried this, but got no further than this:

When I open a terminal in the restore client, I am able to ping my backup server by hostname, so internet is good and DNS also.

If you want to debug, there should be log (or txt) files in the the /root directory.

Edit: The file is /root/restore_mode.txt. You might also get log information via journalctl -u restore-client-internet

Hi Uroni,

I found the connection-problem. By “Server URL” it says -in grey- “urbackup://example.com”:
This creates the following error in the log:
Then I tried something like “19999”:

So now I gave only the hostname without the “urbackup://” and it works.

But sadly, the same error occured: Disk too small…

What does lsblk -x MAJ:MIN -o MAJ:MIN,MODEL,SIZE,TYPE,PATH output?