Unable to mount RAW image file from the GUI

Getting this error on Ubuntu 23.04:

ERROR: Image mounting failed: Guestmount…
libvirt: error : internal error: libvirt.so is not safe to use from setuid/setgid programs
libguestfs: error: /usr/bin/supermin exited with error status 1.
To see full error messages you may need to enable debugging.
and run the command again. For further information, read:
You can also run ‘libguestfs-test-tool’ and post the complete output
into a bug report or message to the libguestfs mailing list.

I have the same error for years now…

For me it helps to just go back to the backup overview and return to the same image backup. Then you will see the mounted files (at least I do). Don’t ask me why I gave up investigating this…

Thanks for the try! Unfortunately, it didn’t work for me :frowning:

Sorry I forgot that this is only half the truth. I found that this only works when I mounted a backup via command line shortly before. Therefore I created a cron job for the root user to mount and unmount an image backup every now and again (mark one as archived so you can always mount this one as it doesn’t go away):

urbackup_mount_helper mount DEVICE 180607-2213_Image_C Image_C_180607-2213.raw
urbackup_mount_helper umount DEVICE 180607-2213_Image_C Image_C_180607-2213.raw

I have been keeping my mouth shut about a lot of these “can not mount images” because I simply do not make img backups and therefore can not test.
But this has been in my mind constantly. I know a few users run urbackup as root, but afaik if installed by default a urbackup user and group is created, and if you use urbackup to mount, well, in my mind it gets mounted by the user urbackup.

Maybe try using another tool for mounting the img (A COPY) and see if that works.

I agree, using urbackup “should work” (or I consider this a bug) but it is what it is.

I did quite a bit of testing a few years ago with different users but it never really worked for me. My current setup is a dirty workaround that I do not understand at all which is bad… but it works for me and I’m not a professional user. I would definitely not accept this solution as a business user :sweat_smile:

But I just double checked: I’m running the server as urbackup user. I also tried root but it did not make any difference. My cron job is executed as root though and it somehow “fixes” the mount problem for the urbackup user temporarily…

1 Like

This actually works!
Thanks so much for sharing :kissing_heart: