Unable to get discovery working (Linux)

I have the client on a box and the server running in a docker container on using --net “host”

On servera I start the client:
root@servera:~# urbackupclientbackend -v debug
2019-07-22 21:25:08: SQLite: recovered 25 frames from WAL file
/usr/local/var/urbackup/backup_client.db-wal code: 283
2019-07-22 21:25:08: urbackupserver: Server started up successfully!
2019-07-22 21:25:08: FileSrv: Binding UDP socket at port 35622…
2019-07-22 21:25:08: FileSrv: done.
2019-07-22 21:25:08: FileSrv: Servername: -servera-
2019-07-22 21:25:08: FileSrv: Server started up successfully
2019-07-22 21:25:08: FileSrv: UDP Thread startet
2019-07-22 21:25:08: Started UrBackupClient Backend…
2019-07-22 21:25:09: Looking for old Sessions… 0 sessions
2019-07-22 21:25:09: Internet mode not enabled
2019-07-22 21:25:09: Final path: /

Now I know that urbackup server is running as I was able to connect from a localhost to create a backup and using netstat I can see it listening:
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0 serverb:35623 serverb:52302 ESTABLISHED
tcp 0 0 serverb:52302 serverb:35623 ESTABLISHED
udp 0 0*
udp 0 0 serverb:35623*

Also: I know udp is working: servera->serverb
root@servera:~# nc -z -v -u 35623
Connection to 35623 port [udp/] succeeded!
root@servera:~# nc -z -v -u 35622
Connection to 35622 port [udp/
] succeeded!

In reverse: serverb->servera
root@serverb:~$ nc -z -v -u 35622
Connection to 35622 port [udp/*] succeeded!

So UDP works both directions, which is good to know when I ping the client I see:
2019-07-22 21:28:39: WARNING: Unknown UDP packet id
2019-07-22 21:28:39: WARNING: Unknown UDP packet id
2019-07-22 21:28:40: WARNING: Unknown UDP packet id
2019-07-22 21:28:41: WARNING: Unknown UDP packet id
2019-07-22 21:28:42: WARNING: Unknown UDP packet id

Finally: TCP connects: servera->serverb
root@servera:~# nc -z -v 55413
Connection to 55413 port [tcp/] succeeded!
root@servera:~# nc -z -v 55414
Connection to 55414 port [tcp/
] succeeded!
root@servera:~# nc -z -v 35621
Connection to 35621 port [tcp/] succeeded!
root@servera:~# nc -z -v 35623
Connection to 35623 port [tcp/
] succeeded!

So why can I not discover the servera from serverb, yet serverb can discover serverb so we know the urbackup server it is up and working. All ports are open and connections work both udp and tcp (though I’m confused by 35622, as I thought it was 35623) and 35623 definitely does not work to servera only to serverb . Also 35621 and 35623 are tcp and not udp on serverb, see netsta results above.

I also tried a Windows client (virtual mahcine) and that was able to connect to the serverb, though it seems hung indexing.

I’m lost as to what could be wrong or blocking discovery of servera. I tried to use the http server “add client” option also without success. I’ve waited as long as 2 hours for discovery to complete and it never happens. It seems as if there is some other port/ports I need to allow which are not documented anywhere, but I can not figure out what they would even be, and I have no FW run blocking any connections between these hosts.

While at it the client can I tell it to bind to only a single adapter if there are multiple ones present, if so how?


you can try to Setting Network Card to Hybrid Mode

Worked it out, I’m sure this is too open, but it is working.
Ports 55413 - 55415 TCP
Port 35621 TCP/UDP
Port 35622 UDP/TCP
Port 35623 TCP/UDP

The first is the one I think is needed, but I could not be sure so I ended up allowing both to get it finally functional.

Also not sure if I need any of the 55413-55415 ports for this, need to try restricting those again.


If you want to be precise (well, as precise as I am … not sure if mine is) you need to open
port 35621/tcp
port 35622/udp
port 35623/tcp

and you should be good to go. That is what I have on my Linux clients.
On the server I have
port 35621/tcp
port 35623/udp
port 55414-55415/tcp

We are not far off each other.

Chin chin