Ubuntu 15.10 urBackup server install

Trying to install urbackup server.

tried the ppa but it told me there was no WILY version available.

DPKG route told me it was broken.

any suggestions for a PPA install? way easier.

tried using the DEB file for debian…

sudo dpkg -i urbackup-server_1.4.11_amd64.deb
[sudo] password for ####:
(Reading database … 145560 files and directories currently installed.)
Preparing to unpack urbackup-server_1.4.11_amd64.deb …
Unpacking urbackup-server ( over ( …
dpkg: dependency problems prevent configuration of urbackup-server:
urbackup-server depends on libcrypto++9; however:
Package libcrypto++9 is not installed.

dpkg: error processing package urbackup-server (–install):
dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.4-1) …
Processing triggers for ureadahead (0.100.0-19) …
ureadahead will be reprofiled on next reboot
Processing triggers for systemd (225-1ubuntu9) …
Errors were encountered while processing:

You should run

sudo apt-get -f install

in order to fix missing dependencies, as per https://www.urbackup.org/debianserverinstall.html

did that. it removed urbackup-server

tried to reinstall, same issue.
ran sudo apt-get -f install and it removed it again…

i’m confused.

That’s quite strange. Give me some time to replicate the issue in a virtual machine.
What version of Ubuntu are you using? Server, Unity, KDE,…?

I found the problem: urbackup-server depends on libcrypto++9, which isn’t available anymore in Ubuntu 15.10, and has been replaced by libcrypto++9v5. Hence apt-get cannot fix the dependencies and proposes the removal of urbackup-server.
You have different options to deal with this:

I would suggest the first option, because I think the others are unsupported hacks.
I honestly don’t know if differences between libcrypto++9 and libcrypto++9v5 could cause any issues; the install completed just fine, but I obviously didn’t carry on accurate functionality tests.

If you plan to deploy this solution in a production environment, the best option should be to use Ubuntu 14.04 LTS, also in order to avoid the hassle of system upgrades every 6 months on a production server. If you are just playing around and evaluating, any solution would be fine.

The biggest problem with downgrading my version of the OS is that the asus
H170m-plus motherboard i’m using is not supported by older versions. I
needed this board for its built in raid, which i was going to use for the
backup data.
This is very much a production environment and i actually tried installing
14.04 but the issues with the motherboard were far too great.

what do you suggest?
This is literally the only software i want to run on this backup server.

Does the Debian version have the same issues?

yep. same issue due to its dependency not being met.

SO the biggest reason i went with 15.10

“The Ubuntu 14.04.3 LTS installation kernel doesn’t support the Intel i219V gigabit controller.”

So unless i dont want internet access… I gotta find a work around somewhere.

Can you add another, hopefully supported, NIC?

I tried… there are only PCIex16 slots… so i havent a NIC that’ll fit.
This is that weird pickle that only linux users feel.
Cant use too knew hardware in fear of support, and too knew of an OS puts you in the drink as well.
THe only way to be cutting edge with linux, is code shit yourself. Wish i had that skill :smile:

You can plug a 1x PCIe NIC into a 16x slot.

i dont have a pcie nic. This is a pretty terrible solution. :stuck_out_tongue:
I’m going to install 14.04.3 without net support and try this…

Have you tried with Debian 8? You will hardly see any difference from Ubuntu, especially if you plan to run your server headless; moreover, you’ll get a very long support cycle without the need for system upgrades.
This is the actual configuration of my server, and I’m very happy with it.
If your NIC is supported, it could be the best solution!

That might be a great idea… I was gonna give is an lxde interface so i’m not fighting the cmd line all the time… but at this point i’m in favor.

i’m gonna try a debian 8 live cd now just to see if it finds the NIC

debian 8 see’s my NIC!! problem is i’m a total newb with debian… pretty similar to ubuntu?
PPA support still available?

Ubuntu is build on Debian, so it’s almost exactly the same thing. I already suggested you try Debian above, but I think I was not clear enough in my post.

As @Flatlinebb said, they are very similar: most commands (basically anything you need for your configuration) are the same.
The main difference lies in the packages’ versions: Ubuntu uses more bleeding edge software, while Debian thoroughly tests everything to ensure maximum stability. This means you could miss some new functionality, but also many bugs!
PPA are Ubuntu specific; there are hacks to use them under Debian but, again, it’s not something I’m gonna recommend on a production server…