Trying to restore a win10 on a new HDD with usb boot image


I’m trying to restore a laptop from a HDD failure. I have a HDD that is the same size as the previous one installed in the laptop.

I have both Image and File backups of the laptop, checked on urbackup server. The VHDZ images mount and allow to download files.


  1. after I boot up the restore usb urbackup image, I get only to restore something called “kb-restore”, although the computer I wanted is named KASIA. I cannot even see this kb-restore on the disk in any other case. The files for KASIA are there, the KASIA computer name is also displayed in the list after I log in into the admin panel.
  2. I tried restoring by hand using this with no luck, after I mounted the remote file system with SSHFS. I cannot restore proper MBRs that would result in a partition table readable by linux. For each of the partitions (C, SYSVOL, ESP) I have one mbr file. Which one to restore?

Since image restore does not work, how successful will I be if I install a fresh win10 install, install just the urbackup client and try to restore just the files on drive C?

Doesn’t matter. They all contain the same MBR.

Are there multiple UrBackup servers running in your network?

1 Like

The files have different SHA sums. But yeah, it is possible that the result will be the same. I cannot get any readable partitions when I restore them to /dev/sda after running partprobe.

second server:
That is a valid hypothesis! How can I check that? I know the IP address of my server. It might have happened that someone has got another one as well.

Can you try hdparm -z /dev/sda or rebooting?

What I’ve tried:

  • restoring the partitions using the --restore-mbr options on a clear disk
  • same, after GPT has been created
  • same, after MBR has been created
  • each time I’ve tried hdparm -z /dev/sda and partprobe
  • on MBR i got “unknown partitions” in dmesg.
  • on GPT i got nothing in dmesg
  • in both cases the partitions did not pop up.

I can create the partition table myself and then try to recreate the bootloader using windows install media. It would be nice to be able to dig out the original partition tables type and partitions geometry from the MBR files.

would it be OK to just “dd” the file over the drive? Or load GPT data from a file using gparted?

I’ve managed to get it booting!

steps taken:

DONE, system booted.

Ok, there definitely was a problem somewhere. Could you send me one of the broken .mbr files?

Sure thing!


I’ll delete them in a week or two.

Things went a bit south, but overall I’ve managed to get the laptop back on its feet. I’m grateful anyway that you’ve created such a nice piece of software that backs up the computers!

The MBR restore via command line does not write the GPT table at all. Will be fixed.