Trying to install UrBackup server into Netgear Readynas NAS (Debian based)

Hello,

I am trying to install UrBackup Server into NetGear Readynas wich is based on Debian 8.1. This is a ARM device. I am using latest versions of UrBackup and Firmware of the NAS.
UrBackup: 2.2.8
ReadyNas: 6.9.2

For some reason I am having some dependency problems. As far as I know I have all correct dependendies in latest versions. Maybe the problem is that this is a modified Debian version and don´t recognize the packages?

This is the error:

root@nas-vultrasa:/tmp# dpkg -i urbackup-server_2.2.8_armhf.deb
Selecting previously unselected package urbackup-server.
(Reading database … 14392 files and directories currently installed.)
Preparing to unpack urbackup-server_2.2.8_armhf.deb …
Unpacking urbackup-server (2.2.8.0) …
dpkg: dependency problems prevent configuration of urbackup-server:
_ urbackup-server depends on libc6 (>= 2.17)._
_ urbackup-server depends on libcurl3 (>= 7.16.2)._
_ urbackup-server depends on libfuse2 (>= 2.6)._
_ urbackup-server depends on libgcc1 (>= 1:3.5)._
_ urbackup-server depends on zlib1g (>= 1:1.1.4)._

dpkg: error processing package urbackup-server (–install):
_ dependency problems - leaving unconfigured_
Processing triggers for systemd (230-7~bpo8+2.netgear2) …
Errors were encountered while processing:
_ urbackup-server_

I have checked first library dependendy problem (libc6) with the command: dpkg -s libc6 | grep Version and obtained the result: Version: 2.19-18+deb8u10.netgear1

I also tryed to manually update libc6 (and the others with apt-get update command) but the sysstem tells me that the version is up to date.

I am not a linux expert and I don´t know where can be the problem.

Any help would be appreciated.

Thank you.

Maybe it is not the same architecture? (dpkg --print-architecture != armhf)

1 Like

Hello @uroni,

The result of this command is: armel

This means that is not possible to install into this NAS?

Would be possible to install server from sources from this NAS?

Hello,
I have installed from sources into my NetGear Readynas, and It works apparently! The problem is that the server service does not start automatically with the NAS. If I start it manually it starts and for a few tests, it seems to work.

I am not any expert in linux and I have some doubts about ./configure and make and make install process.
I have do ./configure and make into the folder where I downloaded the sources. Then I run make install but, as far as I can see, it makes the executable and installation into the same folder of where I am? Is this correct? At the end I have a folder with the sources and the final executable toghether?

I have follow the instructions to put urbackup in the system startup but the service does not start. I have found a configuration file with a username “urbackup” inside, do I need to have this user in the system?

I know these are questions not directly related to UrBackup but I will apreciate some help about it.

I am very persistent when something interests me, and this software interests me

Thanks a lot.

Hi

Usually when you run “make install”, it copies everything in the right place.

if you type
command -v urbackupsrv

it should display
/usr/sbin/urbackupsrv or /usr/local/sbin/urbackupsrv

as for starting at boot :
https://www.urbackup.org/server_source_install.html

either this from the place where the sources are:
cp urbackup-server.service /etc/systemd/system/
systemctl enable urbackup-server.service
cp defaults_server /etc/default/urbackupsrv
cp logrotate_urbackupsrv /etc/logrotate.d/urbackupsrv
systemctl start urbackup-server

or that : put /usr/local/sbin/urbackupsrv run -d into /etc/rc.local.

1 Like

Hi @orogor, @uroni

Many many thanks you!! It works!!

I am going to test it intensively before put it in a production environment, but there are good perspectives!

@uroni, there is any chance to create an armel architecture distribution for further releases?

Cheers

Unfortunately I am running in some problems when do file backups.
First complete backup runs apparently correct, but at the end, it runs in some errors related to free space of the storage. Currently I have 2 Disks of 2 TB and I have 1.8 TB of free space.

One strange thing is that in the Server Web UI, in the Status page, in the column of File Backup Status for my client it shows “No paths to backup configured”, and I have some paths configured.

These are the errors in log:

WARNING: HT: No free space available deleting backups…
2018-03-06 19:12:03: Space to free: 3.27675 GB
2018-03-06 19:12:03: Free space: 1.12094 GB
2018-03-06 19:12:03: Free space: 1.12094 GB
ERROR: HT: FATAL: Error freeing space
2018-03-06 19:12:34: WARNING: Metadata file and “/data/backups/rlopez/180306-1910/CORREO/outlook.pst” do not exist. Skipping applying metdata for this file.
2018-03-06 19:12:34: WARNING: Not all folder metadata could be applied. Metadata was inconsistent.
2018-03-06 19:12:34: Flushing FileClient…
2018-03-06 19:12:34: Writing new file list…
2018-03-06 19:12:34: All metadata was present
2018-03-06 19:12:34: Transferred 3.22829 GB - Average speed: 446.335 MBit/s
2018-03-06 19:12:34: Script does not exist urbackup/post_full_filebackup
2018-03-06 19:12:42: ERROR: FATAL: Backup failed because of disk problems (see previous messages)
2018-03-06 19:12:42: Time taken for backing up client rlopez: 2m 20s
2018-03-06 19:12:42: ERROR: Backup failed
2018-03-06 19:12:42: Updating statistics…
2018-03-06 19:12:43: server_prepare_hash Thread finished (exit)
2018-03-06 19:12:43: server_hash Thread finished - normal
2018-03-06 19:12:43: msg=WAKEUP
2018-03-06 19:12:43: Updating image stats…
2018-03-06 19:12:43: Updating file statistics…
2018-03-06 19:12:43: Done updating statistics.
2018-03-06 19:12:44: ERROR: FATAL: Backup failed because of disk problems (see previous messages)
2018-03-06 19:12:45: msg=WAKEUP
2018-03-06 19:12:45: WARNING: Exponential backoff: Waiting at least 1h 20m before next file backup
2018-03-06 19:12:45: server_prepare_hash Thread finished (exit)
2018-03-06 19:12:45: server_hash Thread finished - normal

from the web ui you need to configure a path to backup in the server setting, then add a path t backup.

Please read the man a bit and take screenshot of your conf

Hello,

I know that I have to configure this. The problem is that the backup runs but at the end it shows the error. During the backup I can see files and folders inside the backup folder. And the disks have a lot of free space.

Seems like for some reason it is not reading free space corectly. I am running with BTRFS snapshot system activated, I have do the test with “urbackup_snapshot_helper test” and it says that is ok.

@uroni can you give any hint?

Thank you

Definitly this does not work. I think this is some kind of problem with BTRFS subsystem. I have readed that BTRFS has a lot of similar problems in some circunstances… and it seems that this is the case I´m having.

I will abandon the idea of having UrBackup running inside this NAS unless there is more support.

Thanks all four your comments.

I have urbackup running on my readynas, there were a few extra steps to get it installed. I have it running fairly smoothly. Have you tried running with debug logging?