Symlink problem with server 2.0.30

Hi,

We have a synology DSM 6 where we save all our urbackup backups. We had urbackup 1.4.9 and we saved all backups in the synology without problems

Since we have updated to 2.0.30 we are geting an error “(err_cannot_create_symbolic_links)” , “(code: 4390)”

Do you know why is this problem with the update? We are thinking of reinstall 1.4.9 but i want to know if someone face this problem before and if you solved it.

Thanks,
/Carlos.

Your NAS does not support an operation which UrBackup 2.x needs. The full error message tells you that.

You need to either install UrBackup on the device directly or use the NAS from Linux.

Other options collected in this thread:

  • Mount NAS storage via iSCSI on backup server
  • Use NFS file sharing to mount the backup storage
  • Create virtual disk images on the NAS and mount them

Thanks for the really fast answe uroni.

Is there a working version of urbackup for DSM 6.x of synology?

You need to either install UrBackup on the device directly or use the NAS from Linux.

We are also having the same problem with a synology NAS DS1513, but we are using it from the ubuntu server.
Is there something in fstab we need to do to allow symlinks?

Make sure the the unix extensions are active for samba. That should enable e.g. cifs to create symlinks.

Looking through documentation and forums, there are no unix extensions to turn on on the synology DX1512+.

But what doesn’t make any sense is that the linux (Ubuntu , Mint) computers backup just fine, wouldn’t they need to create symlinks as well? if it just copying files whether it is from linux or windows once the files are copied to the tmp folder, symlinks would still be needed to copy files onto the nas?

The server is Ubuntu14.04LTS with a 14TB Nas drive mounted in fstab. Workstations are a mix of windows 7, Ubuntu and LinuxMint. I do have one Remote Server 2003 that is still on client version 1.4.11 that backups up files just fine.

Any other direction of what I need to look at?

here is a daily log off of one of the windows workstations:

Starting incremental file backup...
Restarting shadow copy of C:\ because it was started by this server
Scanning for changed hard links on volume of "C"...
Indexing of "C" done. 1804 filesystem lookups 121937 db lookups and 179 db updates
pc-james: Loading file list...
pc-james: Calculating file tree differences...
pc-james: Calculating tree difference size...
pc-james: Linking unchanged and loading new files...
Error getting complete file "5i772WUsdYcxoa30LrHN|C/$$Recycle.Bin/S-1-5-21-806906945-196648528-2586984966-1000/$$RXVMS6I.doc" from pc-james. Errorcode: CANNOT_OPEN_FILE (3)
Creating symlink at "/media/nfs/urbackup/pc-james/160718-1226/C/Documents and Settings" to "C\Users failed. Permission denied (errorcode=13)
Waiting for file transfers...
Waiting for file hashing and copying threads...
Saving file metadata...
Not all folder metadata could be applied. Metadata was inconsistent.
Writing new file list...
Fatal error during backup. Backup not completed
Transferred 100.662 GB - Average speed: 41.2924 MBit/s
Time taken for backing up client pc-james: 6h 5m 1s
Backup failed

It looks like it is being rejected by the urbackup server, not the nas?

A quick google gets me this: https://forum.synology.com/enu/viewtopic.php?t=106563

There is an option fpr unix extensions in the gui of the control center
of file sharing in the advanced settings, but it does not seem to do
anything.

But really you need to post in the synology forums or contact Synology support.

UrBackup Server 2.x needs backup storage with symlink support, otherwise it may or may not function properly.

I have been using 1.4.x for a while and running server on a 2003 server. I has worked great with few issues. It backups clients up to a Cisco NAS which is Linux based. Cisco stopped supporting the NAS a while back. I’m not even sure which Linux distro is running on it. The NAS has 6TB of storage and I hate to not be able to use it. I guess the only way would be to hack it and try to reload another Linux distro, but this would probably be more work than purchasing new hardware.

I installed latest version of urbackup 2.x on a 2012r2 VM and have encountered the symbolic link issue and backups do not work.

Its a shame there is no work-around to get Urbackup to work with older NAS gear.

Thanks,

JC

Also, I tried to get 1.4 working on 2012r2 VM. Urbackup installs but the service is not installed. I don’t know if there is a way to force the service to install or whether it would even work if it were installed. Can anybody lend advice?

I need to get urbackup off of SVR2003 due to so many security flaws in Windows SVR 2003.

If your NAS has the capability to export storage via iSCSI use that.

If it only has Windows file sharing one can also create a virtual disk on the file share. On Linux with dd and losetup. On Windows by going to the computer management, then disk management, other actions, create virtual disk and then save that on the network share.

Correction: – Just a bit ago, I shutdown 1.4 server and started 2.x. I upgraded it to latest release and restarted.
Low and behold, Urbackup is showing the symbolic links error, but it is backing up clients to the NAS.

What are the implications of letting it run with this error? I am doing file backups only.

uroni, THANK YOU for your contributions and quick reply!!!

I can export via ISCSI. I can do that and wipe current backup sets, but at least I do away with error.

i revert back to 1.4.14 but its keep get error password wrong?

Hi JasonC,

I had the same symlink error. Windows server 2k8R2 and a synology NAS. I couldn´t be able to solve it and decided to mount a new server in Debian for urBackup. The error still there as you said so i had to create from cero all the backups. (my fault; i didn´t make the backup of the config files to come back to 1.4.X :frowning: )

Anyway from a debian to a synology NAS it works fine.

¿Do you have mounted with nfs? I mounted that way and just working fine.

no I don’t. Not completely sure how to do that, but will look into it. it is either that or wipe it and go back to 1.4

I did it with 2.0.30

In fstab added the next line
ip_of_the_nas:/volume1/Backup/Staff_backup /Staff_backup nfs soft,intr,rsize=8192,wsize=8192

(ip:/FOLDER IN NAS /FOLDER IN SERVER PARAMETERS)

You will need to create a user in the NAS with the same name and pass that you have in the server

Thanks. I will give that a try in the morning

use 1.1.14 version