[success] Server install on Linux AUSWRT_MERLIN armv7l

I found the link for arm for ver 1.2, couldn’t find one for latest release.
Would like to run in a chroot debian running on asuswrt-merlin, dual core armv7l

uname -a
Linux RT-AC68U #1 SMP PREEMPT Thu Jul 16 23:26:07 EDT 2015 armv7l GNU/Linux

Found this text but couldn’t find debian stable folder with arm inside to download

For Debian stable there is also an ARM package (for e.g. Raspberry PI or Cubieboards).

If not prebuilt available, should i try the raspberry one or try to compile as the instructions seem pretty simple (but I have not compiled from source previously so not sure what i am getting myself into)?

Thanks very much, looking forward to trying this software out

The raspberry pi 1 I set up back then at some raspberry colocation is still running and doing nightly builds:

Let’s see when the company doesn’t want to do that anymore (free colocation) or when it breaks :smile:

Note: Raspberry PI had an ARMv6 CPU so you might get better performance if you build it for your newer ARMv7 CPU.

OMG that was a quick reply and i even think you are the developer. wow

no go for armhf on armel, but the upside is i now know for sure what my system is

wget http://raspberrybuild.urbackup.org/nightly/urbackup-server_1.4.9.1225-1_armhf.deb
–2015-10-03 23:22:47-- http://raspberrybuild.urbackup.org/nightly/urbackup-server_1.4.9.1225-1_armhf.deb
Resolving raspberrybuild.urbackup.org (raspberrybuild.urbackup.org)…
Connecting to raspberrybuild.urbackup.org (raspberrybuild.urbackup.org)||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 2171150 (2.1M) [application/x-debian-package]
Saving to: ‘urbackup-server_1.4.9.1225-1_armhf.deb’

urbackup-server_1.4 100%[=====================>] 2.07M 333KB/s in 6.6s

2015-10-03 23:22:54 (322 KB/s) - ‘urbackup-server_1.4.9.1225-1_armhf.deb’ saved [2171150/2171150]

dpkg -i urbackup-server_1.4.9.1225-1_armhf.deb
dpkg: error processing archive urbackup-server_1.4.9.1225-1_armhf.deb (–install):
package architecture (armhf) does not match system (armel)

I don’t know nothin about buidling so just gathering links here as i find them
How to Compile Packages on Chrooted Debian
Headless for server
Install UrBackup server from sources
some guy installin an a feenas jail and discussion (i am alsu using a type of jail)

Since i don’t know what i am doing, might as well document my build attempt

wget http://hndl.urbackup.org/Server/1.4.9/urbackup-server-1.4.9.tar.gz
tar -xvf urbackup-server-1.4.9.tar.gz
cd urbackup-server-1.4.9

here is my first error, tried this command

./configure --enable-headless

had some errrors, so i tried this but don’t believe it did anything

apt-get install gcc

since that didn’t solve any of those problems, so i tried

apt-get install build-essential
./configure --enable-headless

i was missing cryptoplugin

apt-get install Crypto++

Note, selecting ‘libghc-crypto-cipher-tests-dev’ for regex ‘Crypto+’
Note, selecting ‘python-crypto’ for regex ‘Crypto+’
Note, selecting ‘libghc-cryptohash-cryptoapi-prof’ for regex ‘Crypto+’
there were like 100 of these lines

apt-get update - said it couldn’t find some armv6l packages so i typed ( i had previously

dpkg --remove-architecture armv6l
apt-get update
apt-get upgrade

Then this, from this page

apt-get install libcrypto++8 libcrypto++8-dbg libcrypto+±dev

that installed, then ./configure --enable headless failed with

configure: error: Your system lacks of libcurl >= 7.20.0
configure: error: ./configure failed for urlplugin

so i tried this

apt-cache pkgnames | grep -i libcurl

hmm i hoped to find something saying 7.20.0 or higher, so i search and found this page that says it requires libcur-devel

%if 0%{?el7}%{?fedora}%{?suse_version}
BuildRequires: libcurl-devel

but that isn’t in the list, the following command returns nothing so not sure what i need to install, or if it is even available.or if i can try with to configure without mail support, but not sure of command

apt-cache pkgnames | grep -i libcurl-devel

Thanks to anyone that has any suggestions.

Just re read this page and discovered --enable headless is for the client, i am working with the server. also solved previous libcurl error with

apt-get install libcurl3

./configure had no errors now, now trying

make install

and it works, connected a couple of clients and backed up 600mb of files. Now i need to see about the proper way to set up.

ps I also installed fedora client from here

cd /etc/yum.repos.d/
sudo wget http://download.opensuse.org/repositories/home:kot1grun/Fedora_20/home:kot1grun.repo
sudo dnf install urbackup-client-nogui
sudo start_urbackup_client --no_daemon --loglevel debug

####compile the client-gui
but i couldn’t figure out the server gui for a bit so also compiled the client-gui, to do that i had to
follow this page

cd ~
mkdir urbackupinstall/
cd urbackupinstall/
wget http://hndl.urbackup.org/Client/
tar xzf urbackup-client-
cd urbackup-client-
sudo dnf install wxGTK
to ./configure i had to install cryptopp-5.6.2-6.fc22.x86_64.rpm and wxGTK3*

did most of the same on ubuntu 14.04 but couldn’t get the gui to run/show (there is a bug i believe) with the tray icon. the logs showed it couldn’t open the pw file so i tried this but no go, headless works though.

###Server available via ssh
> modify section 4.2
I already had some fast cgi stuff set up from owncloud so didnt need to modify the lighttpd.conf or add the fastcgi.conf files just do the link. my paths are below

#my lighttpd file
#my webroot
ln -s /tmp/mnt/sda1/entware.arm/debian/usr/local/var/urbackup/www urbackup
#my fastcgi.conf file
nano /opt/etc/lighttpd/conf.d/99-rtorrent-fastcgi-scgi-auth.conf
#restart lighttpd
/opt/etc/init.d/S80lighttpd restart
#ln line
ln -s /tmp/mnt/sda1/entware.arm/debian/usr/local/var/urbackup/www urbackup

access via

But unfortunately i the body of the page never loads (just loading with spinner), everything else does (the banner across the top, and the about at the bottom).

That is odd, i did try the fastcgi conf modification but then i would get an error 451.
I can still log into owncloud so my lighttpd is working,?

###Autostart on boot

#ssh to router and edit startup script
nano /opt/etc/chroot-services.list
#add these two lines
#Copy scripts
debian enter
cp /usr/local/sbin/start_urbackup_* /etc/init.d/
#restart debian
debian restart

##client on fedora autostart
create or edit this file


add this line


When i tried the following line it didn’t work, also didn’t work trying the gnome gui startup with this line, i either get wrong password or can’t bind to port (cause it is already running) in log


I tried to use systemctl to do it but didn’t get it finished. i edited this file and changed this line

sudo nano /usr/lib/systemd/system/urbackup-client.service

At which point it would try to add it but still gave this error, with without the killmode=process, it gave worse errors