Stuck at MBR and GPT restore

Later Edit: All this was because the target disk was too small. In my rush I didn’t realize the source was 1TB and I was trying 250GB as target. Playing with too many disks this week!

Hi, I’m just trying to do a fairly simple proof of concept, this time on Windows.

UrRrestore 2.4.0
UrBackup 2.4.14
UrClient 2.4.11(x64)

I install the server on Server 2019, pretty much defaults. I did change from compressed VHDZ to uncompressed VHD after my first backup, but then I changed it back again and made a new backup.

Install client on Window 10 Home PC, it starts full image backup automatically.

Replace the hard drive in the PC with another of same model.

Create restore USB stick, and boot to UrRestore GUI.

It finds the servers, I choose the client, image and disk. Click to start.

Then I get

“Loading MBR and GPT…”
“Loading MBR Finished…”
“Writing MBR and GPT data to disk…”

That’s is as far as it goes. I see no activity on the screen or in server console.

Any ideas?

Thank you for reading.

You’re probably using the new graphical interface? That might still have problems…

If possible please open a web console and see if there are any errors there (ctrl+shift+i).

See if it is a problem caused by the new version by trying .

Also recently it got a 2.4.1 update. It fixed something in that area, but not your issue specifically.

1 Like

Hi, The console is showing no errors, Server found is the last message.

Other stuff to do:

  • It has log files in /root (*.txt, readable via sudo)
  • Install htop via apt update && apt install htop and see if it hangs in e.g. sgdisk or if any thread hangs in D state

What is the su password?

I tried 2.3.1 and it was a lot more verbose, said the GPT was corrupt so I chose option O, then it came back and said the partition was too small(?). I could not find the options to completely wipe the disk. Same result with 2.4.1 as earlier, hangs at Writing MBR GPT.

Maybe I should dispart, clean this thing and try again with 231. Or I’ll try to find another larger drive. These are 250GB and I have a bunch of them, all the same.

I got it working with a 1TB disk.

Interestingly I got the same error with another brand 250GB disk.

I’ll keep playing and seeif I can get it to restore to same make and model.

1 Like

If you you attach the .mbr file (It only contains a bit of metadata and MBR + GPT) and post the exact size you are trying to restore to. The new restore should be improved to handle this better…

1 Like