Storing file failed -1 Error


Been using urbackup for about 2 months and its been working great its an awesome bit of software. I have one client pc that backs up over the internet that keeps failing due to Storing file failed -1

Backup seems to complete its when the file is being copied from the temp folder it keeps failing on one particulare file that is 79GB large (its Block differences hased incremental)

error log looks like

Errors 27.11.15 06:05 Storing file failed -1
Errors 27.11.15 06:05 Fatal error during backup. Backup not completed
Errors 27.11.15 06:06 FATAL: Backup failed because of disk problems
Errors 27.11.15 06:06 Backup had errors. Deleting partial backup.

I have checked and the storage drive is not faulty plus has plent of space and there is no Anti-Virus on the server that could be causing any issues.

am i missing something? Please help

I’m not sure if this helps troubleshoot but the windows event error i tracked down is 141 and states
{Delayed Write Failed} Windows was unable to save all the data for the file E:\urbackup\ABM\151124-0051\volumeFinance_database\WHATNOPAPER.FDB; the data has been lost. This error may be caused if the device has been removed or the media is write-protected.

Seems like an error originating from the server OS rather than from Urbackup…
Have you tried to manually copy the file in the backup destination folder, to see if that works?

Hi Luca91,

Thank you for your response I’ve tried copying into the clients backup folder to see if there are any errors with file size, creation rights in the folder ect. and don’t have any errors doing so. i have 15 clients all backing up the same way and they all work without issue this is the only client with a file that large.

The server is running windows server 2012

Do you have NTFS compression on for the backup storage?

Hi Uroni,

Yes I am using NTFS compression. is this what is causing it?

Could be this issue: Basically there is a (non-fixed) file size limitation on compressed ntfs files (depending on compressability of the file and how many fragments a file has).
Unfortunately UrBackup does not log the error code. You could use process monitor to confirm this, I guess – or copy the large file manually and look if the explorer reports an error (it could be that the pattern UrBackup writes the file with causes the issue, however).

Hi Uroni,

Thank you for your help it was the NTFS Compression. I set the urbackup folder for the specific client to uncompressed and worked like a charm