SSL for UrBackup webinterface

Hey everybody,

i need help. How do i activate SSL for my Urbackup webinterface? I added a symlink like this: ln -s /var/lib/urbackup/www urbackup. But how do i set the ’Option +FollowSymLinks’ in the webserver configuration and what ist the next step?


The following method works to me. I am using ubuntu 12.10 with apache2. The default has option +followsymlinks enabled. I just need to create a softlink which you did as well and install libapache2-mod-fastcgi then modify fastcgi.conf

Quote from Document chapter 3.2
3.2.1 Apache configuration

Either add a symlink to the ’www’ UrBackup directory or define it as an alias. For the symlink method you need to go to your SSL webroot and then do e.g.:
ln -s /var/lib/urbackup/www urbackup

Be sure you have set ’Option +FollowSymLinks’ in the webserver configuration on the directory you link into. From now on it is assumed that urbackup should be accessible via
https://hostname/urbackup . Download and install ’libapache2-mod-fastcgi’ (this may have another name on other distributions). Add following line to the ’fastcgi.conf’:
FastCgiExternalServer /var/www/urbackup/x -host

The path depends of cause on where your web root is and where you want the web interface to be. UrBackup should now be accessible via apache.

I know this is a dumb question but where is the fastcgi.conf on apache2, ubuntu 16.04

Should be in /etc/apache2/mods-enabled/