SSL apache fastcgi windows

I’m trying to run Urbackup with SSL with apache 2.2 and fastcgi under windows 8.1, but i don’t succeed.

I have SSL with apache up and running.

I made a symlink with mklink in
C:\Program Files (x86)\Apache Software Foundation\Apache2.2\htdocs\urbackup to
C:\Program Files\UrBackupServer\urbackup\www

Downloaded mod_fastcgi.dll
and renamed/copied it into modules.

modified the apache httpd.conf with

LoadModule fastcgi_module modules/mod_fastcgi.dll

Options Indexes FollowSymLinks ExecCGI

DirectoryIndex index.html index.htm

FastCgiExternalServer “C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/urbackup/x” -host

Restarted Apache Service without Errors.

But when I fire up
only the “loading” indicator turns infinite.

I tried to telnet 55413
but there is no answer. Is Urbackup FastCgi running in the windows version?

What am I missing?

Sorry, it seems to be not enabled on Windows. Use the attached args.txt to enable it (after restarting the service). Will be corrected with the next point release.

args.txt (257 Bytes)

Thanks a lot! Now it works.

Is this issue fixed in version 1.4.8? I am experiencing almost the same symptoms with similar setup.

The only difference is that i can telnet 55413.

Any other things to check?

This worked for me if it will be any help to you:

Thanks! I did exactly that for Apache on Windows too. But somehow it did not work out for me…I tried setting this up with nginx instead and it works.

I am looking for a way to do this on IIS too.

Could you provide detailed steps on how you did this? Not real experienced in web servers outside of IIS and I would love to get SSL working