Specify individual files for backup


I’m currently testing out UrBackup Appliance and it seems that it’s not possible to specify an individual file to backup on either Windows or Linux. Is this correct or have I missed something?

So for example, if I want to backup /etc/default/urbackupclient my options are:

  1. Backup the whole /etc/default/
  2. Create a prefilebackup script to copy/rsync the file to a different directory
  3. Create a cronjob to copy/rsync the file to a separate directory

These aren’t deal breakers per se, but it does seem odd to not be able to backup individual files.

Have I missed something?

Despite the name, adding the file works (might not work with the tray GUI…) urbackupclientctl add -d /etc/default/urbackupclient (or add it on the server).

Other options:

  • Backup /etc/default and specify default/urbackupclient as include pattern.
  • Backup a folder where there is a symlink to /etc/default/urbackupclient and enable follow_symlinks for the folder

Thanks @uroni. That’s handy to know. What’s the workaround for Windows? Just specify it in client settings on the server side (which I’ll be using anyway)?

Also, it might be worth adding this little nugget of information to the documentation? - https://www.urbackup.org/administration_manual.html#x1-640008.3.4

Side note: Would be great if you moved the docs to ReadTheDocs and we can contribute changes.

That or use the client cmd there ( "C:\Program Files\UrBackup\UrBackupClient_cmd.exe" ).

If you can stomach working with latex patches for this are of course welcome:

Yes, I found that yesterday. Using the cmd client is going to be my way forward on both Windows and Linux so that the “experience” is the same.

:smile: Maybe I’ll come back to this in a few months when I hopefully have a bit more spare time. Would be a good way to contribute back.

I found an interesting “problem” with this option of specifying a specific file to backup. Basically if the file gets deleted, then the backup will fail. You need to add the “Optional” option by adding -o so it should be:

urbackupclientctl add -d /etc/default/urbackupclient -o

Just in case anyone else runs into this