Some zip files becomes corrupt when downloading them from backup gui

I made some questionable mistakes with my partition creations when installing my linux workstation, so I remade the whole installation feeling confident that I have backups of /home/USER.

Reinstalled linux and downloaded the urbackup client. It connected automatically because I used the same name of my computer.

I tried downloading the whole /home directory. Seemed to work fine but when trying to open the zip file, it said it was not a zip file or in “and old format”. I thought it had something to do with me missing software to read the file so I tried installing different old zip programs, but with no success.
I then tried to download only the /home/USER/.settings folder to a zip file, and that worked!

Lucky for me, I could activate RESTORE=server-confirms in /etc/default/urbackupclient and that restored the whole /home directory when pressing the restore button in gui, but why is this happening?
I was lucky I could do a restore this time, how do I fix this?

So I did some more looking into this.

I noticed that the compression is performed on only one of my cpu cores, this means the download is pretty slow on from my rpi, 8MB/s.

I have narrowed it down to the .local directory in $HOME
Went deeper and tried a few individual directories and some work but the steam directory shows the same error, “’ failed with the following error: Failed to open archive: Not a zip archive”
Are there certain files urbackup or the compression program urbackup is using can’t read?

It’s not a size thing, I tried restoring a directory containing huge files, and that worked fine.

Is there anything I can provide, logs or anything, that can help you help me figure this out?