SOLVED: UrBackup folder size reports 5.56TB while drive is only 4TB


#1

I’ve been doing incremental backups on UrBackup folder of RAID5 4TB drive (S:\Urbackup) on Win Srv 2008 R2, and currently filled 2.8TB. I’ve decided to move the backup to the new external 5TB drive, but it fails with “not enough space at the destination drive” after scanning for few hours.

Looking at the Windows Explorer, it shows ~1.2TB free of 3.63TB, which is correct. However, when I open the property of the folder UrBackup, it shows 5.56TB. I’ve googled and seems to be some bug in windows causing miscalculation of the folder size. But these complaints are all underestimating the actual size. In my case, it’s far exceeding the actual size.

So, thinking it’s possibly just the miscalculation by Windows, I’ve attempted third party backup program (SyncBack), which doesn’t care to scan and calculate the size, to copy the folder. But after several days of copying, my new 5TB has filled up while 560GB is still needing to be copied. How is this possible?


#3

The best way to move the backup storage directory is built in to UrBackup server. See section 10.8 of the Administration Manual.


#4

The reason I was manually moving the folder was that migration wouldn’t start. I’ve created “c:\Program Files\UrBackupServer\urbackup\migrate_storage_to” file with the content “X:\UrBackup”, and restarted the server. But the migration never started, I deleted the file and repeated few times, but the migration would never start.

Not sure how the backup folder exceeded the size of the drive by 1.5TB, but went out and got 10TB drive and restarted the move. After couple of days, there were too many errors, especially the file path being too long. So I cancelled it.

I decided to tried the migration again, and the it’s working now. The only difference this time was that I created the UrBackup folder in the destination drive. I thought the server would create the folder at the destination drive, and by creating a folder will cause a duplicate folder name within.

It’s all good now. Thanks.