Slow Windows Client backups?

I’ve just set up a new server (on RHEL6) with multiple Windows 7 64-bit clients. All appears to be working, but file backups run at a consistent 50KBit/sec.

For testing, I also installed the client on another RHEL6 server and that backed up at 11MBit/s, so it’s not a throughput limit of the server. SFPT copies from the Windows 7 clients to the server run at 30MBit/s and upward.

Would anyone have any suggestions where to start debugging this.

1 Like

Strangely enough, it seems to be related to power management on the clients. Most are Lenovo laptops with their power management utlities. If I change them to allow max cpu usage, then the backups go at full speed.

Thanks for finding this out. The client transfer is done with a background task priority. I guess some Lenovo engineer thought they would save battery if the background tasks are throttled (which is true). Unfortunately I can only set it to background or run it at normal IO priority. So the background priority is definitely the correct one (Normal foreground applications should not be slowed down by the backup running in the background).

I think there is the same isue on my Server!

It´s a brand-New and quite Performance Server (actual Intel-Xeon, SSD´s etc.) … and the Backup is terribly slow. (maybe a few Kilobytes per Second)

There is no CPU ultilization and nealy no HDD operation. Also the Power-Management is set to “Performance”.

I´m running Windows 2012R2

How can i get it working? @rscott how du you deactivated your Power Management

Thanks for any help!

I have an update about this issue, after some investigation.

After I installed the new 1.4.8 Client on an other PC (Windows 8.1, other Hardware) and then changed the urbackup-server i had the same issue with an other urbackup-server (also version 1.4.8, on a raspberry-pi, raspberrypi nearly no ultilization during backup, what is nearly impossible :wink: )

Also i knew that this client before was working on the old urbackup-server but maybe in the Version (1.4.7) i tried to downgrade to 1.4.7 client-version during still keeping the 1.4.8. server-version on the raspberry-pi and it worked.

Then i tried to preproduce my test on the previous called intel-xeon (just removed the 1.4.8 client completely and installed the 1.4.7 version) and everything worked perfectly!

Maybe there is some issue in the new client-version in combination with Windows 8.1. / Windows 2012 R2 (which are the same base) ?

I would help you with pleasure to debug this problem. If i can do something for you to test or investigate for you, please let me know!

P.S.: i used the 1.4.7 64bit msi-version from sourceforge ( and the 1.4.8 exe-file direct from page (which is the 32bit build ?) maybe this can also be interesting))


The .exe installer autmatically installs the 64bit binaries on 64-bit systems. See download description.

You can try 1.4.9 from here and disable the “background priority” on the clients: UrBackup Server and Client 1.4.9

Your slowness could however be caused by the rasperrby pi hardware.

Your slowness could however be caused by the rasperrby pi hardware.

You misunderstood me. I have two diferent urbackup-server on different locations:

on the raspberry-pi-server, with Windows 8.1 Clients as following:

  • with 1.4.8 on the there is no ultilization of io/cpu, and urbackup-server/client does nealy nothing, so raspberry is not limiting
  • with 1.4.7 the raspberry-pi is running at 100%-CPU and every works fine (slow but at max of it´s capatibilities)

on the xeon-server with Windows 2012 R2 client:

  • with 1.4.8 also nearly no ultilization and slow performance (maybe 30-50kb/sec)
  • with 1.4.7 everything works fine, … backup of around 100GB in < 60 minutes

I will try the 1.4.9 Version and give futher information.



I am having this problem on a tablet and another laptop. days it will take days. any other solutions?

There is an option “Run backups with background priority on the clients” in the advanced tab now which one can disable.

The client runs in the background to not disturb foreground applications. Depending on the hardware the Windows energy management sometimes interprets this as “throttle application down to near zero” if on battery.

Nice that help one laptop but the other the wifi is just too slow i checked the speed.