Slow file backup, but the same speed on several virtual clients


#1

Hi!
I have read already all posts on slow backup, but it does not seem to be my case.
So when I’m doing image backup, it runs at about 180Mbps, but if I try to do file backup for the same volume on same server, the maximum speed is 17Mbps. I already tried to disable and even uninstall antivirus. No “background priority” set. No resources high usage. Disk queue on both server and client is below 0,1.

BUT the interesting fact is that if I split client into virtual clients and do backup of different folders on the volume at the same time, three simultaneous backups run at 17Mbps! What the heck?


Server: 2.3.7 version on Windows 2008R2 Standard x64
Client: 2.3.4 version on Windows 2008R2 Standard x64


#2

have you unchecked setting Run backups with background priority on the clients under settings?
afaik it could cause especially windows running file.backups faster. but i’m not sure.


#3

Weird. Are you backing up lot’s of small files or does it get faster with large files?


#4

That’s what I saidin my post. “background priority” is unchecked


#5

I do. But with big files 30-50Gb it does not get any better.
Example: 1Gb file below


#6

I was getting the same problem. But in KB, no even MB. Don’t know if this is the same situations as yours.
After digging, the LAN clients had the “internet server” checked. So for some reason they used the gateway and maybe through the WAN.
So I made a group for LAN clients, and remove the internet check from server in the group.
The speed increase immediately


#7

Don’t rule out driver problems or Windows QoS settings, both frequently cause odd or inexplicable slowdowns, it’s worth experimenting with disabling QoS and any related driver settings.


#8

Ok, so I think the difference is that the image upload sets the Windows TCP send buffer to 512KB and for local file backups it uses the default Windows send buffer (which is supposed to auto-tune itself). So it should be faster if you use the Internet mode locally.
See e.g. https://curl.haxx.se/mail/lib-2018-07/0080.html for performance implications. So the solution may be to use the same round-about tuning as the curl fix.


#9

Ok, so I think this does not apply, since UrBackup doesn’t use non-blocking sockets in this case. What does

netsh winsock show autotuning

say on the client?


#10

Thank you! I disabled TCP autotuning and chimney on servers as it causes for some reason slow file transfer. servers. But I haven’t check winsock autotuning. It’s enabled. Shall I disable it? On client or server?


#11

Thank you, Riccardo. It was not my case. But I even tried to enable internet client to see if the speed would be faster. It didn’t help and I switched back to local


#12

Just tried disabling QoS. Let’s see what happens.
BTW, file transfer with Windows Explorer runs fine with highest speed…


#13

After disabling QoS on client the maximum speed jumps up to 50Mbps! But it’s not stable. I’ll take a look for a couple of hours and see if it helped. Thanks!


#14

today my backups transfer are soooo slow too!
strange cause the fiber is up to 1gb/s and there was not any change on the system…strange!


#15

I’ve been on vacation. So far on my return I can say that no progress in speed after disabling QoS. But I have a workaround:
4 simultaneous backups run at maximum speed of 20Mbps each and total time of backup is reduced 4 times (still too slow – 1 week instead of 2 weeks)

Best regards,
Regstaer Group of Companies


#16

I cannot figure out whats is going on. The past week all was good and fast. Now I cannot got better then 10 kb/sec con remote backup. The lines are ok and 1 gb/s

but, little update. clarify me on this please.
Now, I see a backup in progress, with a speed of 230 kb/s (very slow for my standard), but if I take a look at the log, there is no such transfer. The program is hashing the files. They are a lot and small. Is it possible that speed is the reading speed of the disk while hashing?

|13/03/19 08:59  |DEBUG  |HT: Renaming file to "xxxxxxxxxxxxxxxxx" with hash output
|13/03/19 08:59  |DEBUG  |GT: Loaded file "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |PT: Hashing file "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |HT: Copying file: "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |HT: Renaming file to "xxxxxxxxxxxxxxxxx" with hash output
|13/03/19 08:59  |DEBUG  |GT: File "xxxxxxxxxxxxxxxxx" not found via hash. Loading file...
|13/03/19 08:59  |DEBUG  |No old file for "xxxxxxxxxxxxxxxxx" (1)
|13/03/19 08:59  |DEBUG  |Loading file "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |GT: Loaded file "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |Loading file "xxxxxxxxxxxxxxxxx" (metadata only)
|13/03/19 08:59  |DEBUG  |HT: Renaming file to "xxxxxxxxxxxxxxxxx" with hash output
|13/03/19 08:59  |DEBUG  |GT: File "xxxxxxxxxxxxxxxxx" not found via hash. Loading file...
|13/03/19 08:59  |DEBUG  |No old file for "xxxxxxxxxxxxxxxxx" (1)
|13/03/19 08:59  |DEBUG  |Loading file "xxxxxxxxxxxxxxxxx"
|13/03/19 08:59  |DEBUG  |GT: Loaded file "xxxxxxxxxxxxxxxxx"

Am I right?


#17

I cannot ifgure out, I need some help. I don’t understand why, all of a sudden the speed drop like this.

14/03/19 08:34  |INFO  |Transferred 154.483 MB - Average speed: 37.976 KBit/s
14/03/19 08:34  |INFO  |(Before compression: 211.483 MB ratio: 1.36897)
14/03/19 08:34  |INFO  |3.60161 MB of files were already present on the server and did not need to be transferred
14/03/19 08:34  |DEBUG  |Script does not exist urbackup/post_incr_filebackup
14/03/19 08:34  |INFO  |Time taken for backing up client Ticket: 9h 29m 25s

9 hours for 154 MB a@ 37 KBit/s in a 1 GB/s fiber


#18

Sorry, m8. I haven’t figure out what is the problem with speed. My backups are still slow. Hope to see improvements in
future updates.

Btw, check if new 0-day updates were installed. Kaspersky found vulnerabilities in graphics subsystem and Microsoft released
patch.

Best regards,
Denis Staroverov Head of IT department
Regstaer Group of Companies
Phone: +7 495 9818700 ext.2213
**GET YOUR 10% DISCOUNT ORDERING AT ** http://www.regstaer.ru


#19

What do you mean? The client are for the most windows and the sserver is a virtual machine linux with an iSCSI attached.
The funny (not so funny) thing is that the installation of all urbackup system has 1 month, and until 3 days ago the speed was ok! I was very happy with this setup…but now this…all of a sudden :\


#20

Ah and the thing is that the LAN clients suffers slow backups too!