Skip symlinks from client backup

Hi, we are using Urbackup server on Windows server 2008 R8, storage is on Synology NAS and clients on Windows 10.

There is a problem with client backup, where is error Creating symlink at … failed. I know, is a problem with NAS settings, but we have shared storage and change it is not possible.

Is there any possibility, how to skip symlinks backup from client? Or how to add filter for symlinks to Excluded files in Settings?

Thanks for your answer, Jirka

As i understand, you want the symlinks_optional flag
look at , section 8.3.4

I wish there were checkboxes for flags too.

I run linux so you’ll probably get different results, but the idea should be the same

if you run something like this it ll show possibles options
urbackupclientctl add-backupdir --help

mines are
-k, --keep Keep deleted files and directories during incremental backups
-a, --separate-hashes Do not share local hashes with other virtual clients
-s, --require-snapshot Fail backup if snapshot of backup path cannot be created
-x, --one-filesystem Do not cross filesystem boundary during backup
-r, --require-symlinks Fail backup if symbolic link targets do not exist
-f, --no-follow-symlinks Do not follow symbolic links outside of backup path
-o, --optional Do not fail backup if path does not exist

on client if you run
urbackupclientctl list-backupdirs
it will show applied options

mines are

/path/to/folder folder follow_symlinks,symlinks_optional,share_hashes

then in the web config of the server you can specify a backup as (use options specified in the doc, first link of the post)

Thanks for you reply. I tried to set up client with options to disable symlinks, but on Windows 10 is still error with Create symbloci links.

I have folder on C:\test, which contains symlink test2 to another folder test3. In client settings is:
Default directories to backup: C:\test|test/optional,follow_symlinks,symlinks_optional,share_hashes

But the flags follow_symlinks and symlinks_optional are not working, because there is no different if I set it or not.
There is still error Creating symlink at “\…\test\test2” to “test3” failed


I have the same issue. I don’t want the client to follow symlinks. In the manual, section 8.3.4, you can find these two options

follow_symlinks | Symbolic links which point outside of the specified directory will be followed | Default
symlinks_optional | Backup will not fail if a symbolic link cannot be followed | Default

As they are default, the client will always follow symlinks, but won’t throw any errors. So we need an option like “no_follow_symlinks” or something. Or how can I disable the default option “follow_symlinks”?

Is this possible with the actual version?



We tried many options, but anything helped to us. Our solution was to change backup destination from NAS with SAMBA to Windows shared folder (mounted from NAS)

Jiří Mizera