Server will not update to v1.4.14

I’m currently running v1.4.10 on a Windows Server 2012 R2 64-bit and trying to update it to the latest 1.4.14. When I run the installer, everything runs fine and even states it completed successfully, but when I browse to the web site, it stills shows v1.4.10. I’ve tried rebooting the server, manually stopping the UrBackup server, and re-run the installer. No good. It will not take the update.

I thought about trying to uninstalling and reinstalling, but I wasn’t sure what all files to backup and restore in order to keep my settings and client information. The setup I have is running the default installation path (C:\Program Files\UrBackupServer) and the server backup storage is located on a 2nd drive.

Any suggestions?


Did you try refreshing the browser page (e.g. with ctrl+shift+R) in case the old web page is still in the browser cache?

I use Chrome and I did, before starting this thread, close out of all Chome windows, but to no avail. However, after coming back from a 3-day weekend, I’m now showing the updated version. Weird, but OK. Whatever. So it had to be some kind of caching somewhere. Stupid cache. Anyways. Thanks for your help.