Server does not connect with client [SOLVED]


#1

I have 9 clients running without any problem. Now I’m trying to add two more clients to the server, however the server does not connect.
After the client installation the server has discovered the new clients and updated the server_idents.txt of the client with the public key (the id of the server is identical in client and server).
The clients don’t show up in the backup-status-section and are not visible in the settings-client section.
I have restarted the server and the clients, removed the clients and re-installed them. The behaviour is again as described above, no connection.
I the tried with “add new client” and provided the ip, nothing is happening.
In ther server & client logs are no entries.
What do I need to do to get the clients connected?


#2

hi

Are all the clients on the same lan and can connect via udp broadcast ?


#3

Yes, all clients are in the same LAN. If I delete all entries in server_idents.txt of the client and past the server ID, then it takes just a few minutes an the server updates the file with its public-key (long string). So clearly yes, the server discovers the client and starts bulding the link, but does not finish for whatever reason.
In between I have three clients waiting for connection, one of them was some days ago already connected to the server. For test purposes, I have removed the client from the server (via gui), removed and re-installed the client.


#4

@uroni: Can you please help?


#5

I ll ask before he does, i guess he ll need the client logs in debug mode.


#6

Thanks for the hint.
Reading and interpreting the Debug info on the server led me to the server settings: Max Clients was too low.
I have increased the number and now the additional Clients have connected :slight_smile:


#7

Hi,
looks like I have the same problem.
I used 12 clients in the past and added no. 13 en 14 last week. No 13 went well but no 14 is still not connected.
Where do you did this setting? And what value do you increased and how much?

Thanks