Server - Client and then separate Server - Client in Reverse

i am successfully running urbackup on openmediavault / docker which hosts my media files on separate ext4 hard drives. i also have urbackup client installed on a windows laptop and so I also get image / file backups working.

although urbackup client is installed on the windows laptop, i also want to install urbackup server so that the windows laptop can backup (in ntfs format) my media files on the openmediavault machine.

So essentially, openmediavault will have a server and client. windows machine will have server and client. will this cause urbackup issues with eacher?

Not really, put a filter to ignore urbackup datastore, and use the same set of ident file for both servers.
Clients can have different config on different servers.
Only restriction is internet server, you can use >1, but it will connect to the 2nd one only if the first is unavailable.

If it’s brand new install , read the doc for btrs and raw image, it will work better than ext4.

I was looking at the urbackup UI but can not find where you would put these filters to ignore the urbackup datastore?

setting
select a client
Excluded files (with wildcards):

ok thanks, so I need to install urbackup server for windows?
and on my openmediavault, i am using a docker image which is presumably the server so what I do install as the client?

I am suddenly not sure i understood you, you need to install the server where you store the file.

If you want to backup omv and/or laptop to laptop, install server in laptop
If you want to backup laptop and/or omv to omv, install server in omv

if omv run on x86 (not arm), the client is available on the main download page of urbackup website.

now i am confused. right now, i have a server installed on omv which is backing up windows clients.

but i also want to backup omv media files to a ntfs system, so i think i need to install a separate server on windows.

windows machine will have urbackup client and server.

then the question comes does urbackup server on omv also act as a client?

No the server doesn’t act as a client, you need to install a client on it.
If the omv processor is x86 (not arm), the client is available on the main download page of urbackup website.

1 Like

The OMV processor is a Dell i5 desktop plus I need to run it as a docker. So I found this which i think will work:

https://hub.docker.com/r/uroni/urbackup-client

The only question I still have is that when I go the UI :55414 on the omv processor, urbackup knows it is acting as both client and server and I need to exclude the directories that omv is backing up on the server side?

I don’t think it knows it is both server and client, there’s nothing that hint that.
It takes 2 min to add the exclusion, so avoid problems and add it. :slight_smile:

ok, so I am trying to install the client on omv using uroni urbackup client stack - its asking for this information, not sure where I find this as the docker website page does give advice:

  - URBACKUP_SERVER_NAME=example.com
  - URBACKUP_CLIENT_NAME=exampleclientname
  - URBACKUP_CLIENT_AUTHKEY=secretkey
  • URBACKUP_SERVER_NAME=example.com this is the name of your omv server
  • URBACKUP_CLIENT_NAME=exampleclientname in your specific case , this is the same
  • URBACKUP_CLIENT_AUTHKEY=secretkey , this you get it from the gui in the internet tab , but it s for internet connection , not needed for you

if your omv is named example.com and you type ping example.com and it is sucessfull, it s the good name to type, or else, just use the ip server

Sorry still a little confised. Would the Server Name be the name of my server on Windows (localhost:55414/) rather than the existing omv server (which is called omvt)?

type omvt in both fields

Anyway, it shouldn’t matter much because of autodiscovery and u can change it later.

No , in fact, you may need internet backup later because of docker networking.
Type in
the name or ip of your windows server as the server
and omvt for the client name.

ok and i also entered the urbackup_client_authkey from my omvt gui internet tab (as it the stack wouldn’t work without it).

so in my case - server name = BuildPC
Client name = omvt
and added the omvt auth key

Stack has loaded Ok, went ot the BuildPC GUI and added new client omvt, but it says not online. The autodiscovery did not find anything.

In order

Maybe it connected first to the local serer and you now have an issue with keys
so look at the foc for ident files , fix that same keys on both servers, restart

Not solved
on the server, display all column, and display all clients, see if there is an error,
If still an ident error ,the keys are not deployed properly

Not solved?
Yes, y am almost sure docker created a new network per stack or something.
So the autodiscover wont work , you have to configure an internet client
Make sure you can ping the server ip you typed from omv, preferably from within the container
If possible also test the port via telnet or nc

Ports are open and telnet/netcat is sucessfulll?
the client name you dont care , its cometic
Try to see if you can manage to setup internet mode from the doc, may have to edit a file in the docker.

Maybe it connected first to the local serer and you now have an issue with keys so look at the foc for ident files , fix that same keys on both servers, restart

ok hopefully I’ve done step 1 ok - from the omv server, i see a server_ident.key and server_token.key file - so I copy both of these across to the windows server folder and restarted both. its been about 10 mins but still showing omvt as offline.

on the server, display all column, and display all clients, see if there is an error,
If still an ident error ,the keys are not deployed properly

on step 2, show all clients from windows server just shows itself (BuildPC) as online but server rejected. It shows the omvt (that I manually per step 1) but offline. Nothing else showing.

havent done step 3 yet as just wont to make sure I have done step 1 and step 2 correct first?

You don’t need to copy the key files. That is only if you want to use two different servers on a client and if you don’t want to configure the client to accept the second server.

You do, however:

E.g. URBACKUP_CLIENT_NAME needs to match the name of the client you added on your Windows server.

ok on my stack (omvt) I have the following I have:

Server Name=BuildPC
Client Name=omvt
AuthKEY=<have inserted secret key from omvt client, settings, internet restore key)

on windows server, then followed 7.3 of manual and added omvt, then gone windows server, settings, enable internet mode, eneter internet server name ‘omvt’, pasted the same internet key. Saved and restarted everything.

but still windows server not connecting to omvt server.