Server 2.0.4 beta + GPT disk

We are trying to backup a large volume on a GPT disk and the filebackup will work fine ut to around 330Gb of 870Gb. Then the activitie in the server just stalls and the client debug log prints out this at the same time.

2016-02-23 09:28:46: FileSrv: Mapped name: \?\GLOBALROOT\Device\HarddiskVolumeShadowCopy9\Shares\FG_Data\FÖRETAGSHÄLSOVÅRD\PRODUKT\Internt Produkt\1. Lillemor projekt\8. Psykosocial undersökning\10. Stimulanspengarna hamnat fel\Stimulanspengarna från J\Sälj-Strategiskt partnerskap vid tidig rehabilitering\Säljpresentation Umeå.ppt
2016-02-23 09:28:46: FileSrv: Reading last file part
2016-02-23 09:28:55: ClientService cmd: #IZzparBlFd312qTgeo29h#2PING RUNNING pc_done=41&eta_ms=84694926&status_id=10&speed_bpms=85.0735&total_bytes=878312442400&done_bytes=358635953554#token=Cq5YW4hCCghexPPVxV0X
2016-02-23 09:29:05: ClientService cmd: #IZzparBlFd312qTgeo29h#2PING RUNNING pc_done=41&eta_ms=84684925&status_id=10&speed_bpms=85.0735&total_bytes=878312442400&done_bytes=358635953554#token=Cq5YW4hCCghexPPVxV0X
2016-02-23 09:29:15: ClientService cmd: #IZzparBlFd312qTgeo29h#2PING RUNNING pc_done=41&eta_ms=84674925&status_id=10&speed_bpms=85.0735&total_bytes=878312442400&done_bytes=358635953554#token=Cq5YW4hCCghexPPVxV0X

The volume is also part in DFSR replication but we have tried to disable this with the same error. Backing up smaller folders on the same volume works so it seems like it has to do with the lagre size of the folder och the number of files.

urBackup Server: 2.0.4 beta
Server OS: Ubuntu 14.4
Filesystem: ZFS

urBackup Client: 2.0.4 beta
Client OS: Windows Server 2012 R2
Filesystem: NTFS on GPT disk

Anyone have any ideas or suggestions.


Is this locally or via Internet?

Thanks for resonding.
The backup is donw on the local lan. Did some more tests yesterday and we can see that the UrBackupClientBackend.exe krasches on the client most of the time. After restarting it seems to try resume for a while before the backup fails.

The UrBackup Client Service for Backups service terminated unexpectedly

  • System
    • Provider
      [ Name] Service Control Manager
      [ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
      [ EventSourceName] Service Control Manager
    • EventID 7031
      [ Qualifiers] 49152
      Version 0
      Level 2
      Task 0
      Opcode 0
      Keywords 0x8080000000000000
    • TimeCreated
      [ SystemTime] 2016-02-24T00:40:39.555521200Z
      EventRecordID 10673
    • Execution
      [ ProcessID] 568
      [ ThreadID] 5080
      Channel System
  • EventData
    param1 UrBackup Client Service for Backups
    param2 1
    param3 60000
    param4 1
    param5 Restart the service

Binary data:
In Words
0000: 00720055 00610042 006B0063 00700075
0010: 006C0043 00650069 0074006E 00610042
0020: 006B0063 006E0065 00000064

In Bytes
0000: 55 00 72 00 42 00 61 00 U.r.B.a.
0008: 63 00 6B 00 75 00 70 00 c.k.u.p.
0010: 43 00 6C 00 69 00 65 00 C.l.i.e.
0018: 6E 00 74 00 42 00 61 00 n.t.B.a.
0020: 63 00 6B 00 65 00 6E 00 c.k.e.n.
0028: 64 00 00 00

Hi again
It is so strange. Repaired the database, reinstalled the client and this time it stopped at 343Gb and the UrBackup Client Service krasches.

This is from the serverlog

It spins there for a while then the backup fails.


Hi again
I just tried the 2.0.5 beta and the client still crashes after a while. This is the client log entries:

2016-03-04 13:19:18: WARNING: Last record not readable at ‘d:’ - reindexing. Last record USN is 48421203920 FirstUsn is 49048190976 NextUsn is 49587581776
2016-03-04 13:19:18: WARNING: There are 1166377856 new USN entries at ‘d:’ - reindexing
2016-03-04 14:42:36: ERROR: Error getting SID of ACE entry of file “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7\Shares\FG_Data\FÖRETAGSHÄLSOVÃ…RD\AFFÄRSENHETERNA”
2016-03-04 14:48:00: ERROR: Error getting SID of ACE entry of file “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7\Shares\FG_Data\FÖRETAGSHÄLSOVÃ…RD\GEM_ARBETSMILJÖ”

Is thera any more information that I could collect that would be helpful.


A crash dump would be great. It does not log that it created one but perhaps you can tell Windows to save them.


Here are the crashdump (101.7 KB)

Thanks. Found the bug. Will be fixed with the next version.

Hi. Tested Server 2.0.7 and client 2.0.6 and now the backup finishes. But it stalls on 100% for a few hours and the CPU usage during this time is high on iowait. We have two identical servers, one with 1.4.12 and the other with 2.0.7, Both Ubuntu 15.10 and zfs and we do not see this problem on 1.4.12.

Any ideas?


What does the last (live) log line say?