Restoring to a VirtualBox Guest

I’m trying to test an image backup I took of my laptop in a VirtualBox VM. I’ve created a virtual hard disk larger than the backed up partition, and am booting from the restore CD image.

The CD boots properly, gets an IP address via DHCP, finds the UrBackup server, allows me to log in and finds the image for my laptop. The actual restore fails with Error writing GPT. I’ve tried with all virtualbox supported virtual disk types (VDI, VDH, VMDK) with no success.

Can you advise whether the restore process is supported inside VirtualBox or is it only on bare-metal?


  • UrBackup Server 2.2.8 on Ubuntu 16.04
  • UrBackup client on Windows 10
  • UrBackup restore CD 2.2.1

Nobody knows?

I can tell you that I tested what you are describing few weeks ago.
It worked flawlessly.
But in my case it was old c2d machine that was client running win8.1, it was being backed up in to a urbackup server running on virtualbox, and restored in to freshly created virtualbox machine…

it was all MBR, so you might want to dig in to GPT in virtualbox and EFI boot.

I think the problem is that the GPT (often connected to EFI) is written to the end of the disk as well. So there is an error if the partition is large enough, but not the disk.

I’ll have a look into this at some point…

Don’t worry, that was it - Virtual disk size. Increased it to ~1TB and it is now restoring.