Restoring from containerized Urbackup Server never working

UrBackup theoretically meets my needs perfectly. I was able to test backing up and restoring containers using the UrBackup Client docker images. It worked exactly like I wanted it to! However, when doing this, I had installed UrBackup server directly on a Windows server.
Eventually, I moved to a containerized version of UrBackup server using Docker and everything seemed to work fine until I tried to restore a backup back to the client.
No matter what image I used, including the uroni ones.
No matter what ports I opened on both the server and the client, nor if I set network mode to “host”.
No matter what firewalls I disable.
No matter what settings I set (Yes, I set RESTORE=server-confirms on the client)
The restore process always spits out the following:

|12/31/21 01:58|DEBUG|Getting client settings…|
| — | — | — |
|12/31/21 01:58|DEBUG|Sending backup incr interval…|
|12/31/21 01:58|INFO|Updated client “codimd” successfully|
|12/31/21 01:58|INFO|Starting restore of path “”. Waiting for client confirmation…|
|12/31/21 01:58|DEBUG|Getting client settings…|
|12/31/21 02:03|ERROR|Restore was inactive for 5min. Timeout. Stopping restore…|

It did not do this on my Windows baremetal installation. I do not know why the containers seem to have this problem, I feel like I’ve tried everything.

Has anyone else been able to successfully restore from a containerized docker image to a containerized client? Some help would be greatly appreciated.

I solved my issue. It turns out /etc/default/urbackupclient is not loaded properly when a container is starting if it is overwritten. It must be followed by service urbackupclientbackend restart

1 Like