Restoring file fails (linux webserver as client)


#1

Hi
I have been looking for a solution to backup our webserver after R1soft Backupmanager stopped working on our new Server with NVMe storage and found Urbackup today which looks like a great software.

So i have installed the client successfully on our Ubuntu 16.04 Webserver and installed Urback-Server on a Ubuntu Server that runs in a VMWare Fusion Virtual Machine on a Macintosh. Sounds a little complicated but actually connected pretty well after some config work.
So i ran a backup successfully and tried to restore a deleted file. But here i only got a timeout message after a while with the following log on the client side:

2018-03-16 19:17:05: Started connection to SERVICE_COMMANDS
2018-03-16 19:17:05: ClientService cmd: #IvCmaDOd9gtKLQXxpZ8nO#FILE RESTORE client_token=6R1RmiPzV96ZVG3ZBQM15t0nIrlDvw/GKipI+iGInd0WXB0QuT5gsZmIc+rhacZuIgz4CZcIu/yA&server_token=nAoG8NA6JTE5fsWHGjJu&id=5&status_id=16&log_id=18&restore_path=ayurvedashop%2FLICENSE.html&single_file=1&clean_other=1&ignore_other_fs=1&restore_flags=64&tgroup=0&clientsubname=
2018-03-16 19:17:05: rc=0 hasError=true state=0
2018-03-16 19:17:05: SERVICE_COMMANDS finished

So as far as i can see the connection from the server to the client for the restore is made but fails. Unfortunately i can not see why it fails.

Anybody out there who can help?
Thanks in advance
Cheers
Gunnar


#2

You d probably need to set server-confirm on the client config file.
It want to show a pop to confirm file restore, but there s no gui to show it.


#3

Thanks for your answer.
i tried to follow your hint but probably need some further information. i looked a bit around on how to implement the server-confirm option.
i thought it would need to go to the following file on the client machine: /usr/local/var/urbackup/data/settings.cfg but putting RESTORE=server-confirms there did not change anything. the entry also gets deleted if i change settings for the client in the web ui
so i looked for urbackupclient in /etc/default but nothing was there so i created a file there with RESTORE=server-confirms. is it really confirms or does it have to be confirm?
well anyway i restarted the client but still no change :frowning:
can you give me some more advice? Its very much appreciated!


#4

Idk how you installed the client but this file shuld be in /etc/default/urbackupclient (on the client): https://github.com/uroni/urbackup_backend/blob/dev/defaults_client

This config file is also a parameter to the client, so you should see it in the ps -Af output.


#5

for me it s :

/etc/default/urbackupclient
RESTORE=server-confirms

# Valid settings:
#
# "client-confirms": If you have the GUI component the currently active user
#                    will need to confirm restores from the web interface.
#                    If you have no GUI component this will cause restores
#                    from the server web interface to not work
# "server-confirms": The server will ask the user starting the restore on 
#                    the web interface for confirmation
# "disabled":        Restores via web interface are disabled.
#                    Restores via urbackupclientctl still wor

#6

thanks for your reply.
for the installation of the client i used the directions from this page: https://www.urbackup.org/client_debian_ubuntu_install.html to install the client on our Ubuntu server.
This was done starting after login with ssh in the following directory: /root/
Don’t know if this was not the ideal place.

From your and orogors post i do now know how to place the option but now i only need to find the right spot since with my installation in /root/ the urbackupclient file doesn’t reside in /etc/default/


#7

i had an idea today. maybe it is possible to start the client from the commandline with the option for restore=server-confirms activated. and yes it is :smiley: urbackupclientbackend -i -v debug -r server-confirms
and with that restoring files works. yeah. Remains the question did my place of installation (/root/) cause the problem with the missing /etc/default/urbackupclient and what can i do to implement this script successfully.


#8

If you compiled yourself, you can put any prefix you want, and usually you use /opt/ or /usr/local

Anyhow , why not do ps aux | grep urb , then look at the --config option to find where it is expecting the config file , then create it there ?
Or you can edit the startup script (from system.d or rc.local, or init.d) then put the path you want there