Restoring backup: Starting restore failed: disabled

Lost my all files and now trying to restore large file backup.
I disabled file backup so it won’t make backups from empty folder.
After long time of indexing (about 12 hours) I got this error in server log:

Starting restore failed: disabled

Does it mean I need to let it make backups from nothing to restore files? Or what is restoring disabled somehow?

Client did not get any errors and it is still waiting for server and says:
"Starting restore. Waiting for backup server… "

Oof sounds stressful. What i would do first is check the box to archive the last (or possibly a couple) file backups that are known to be good, just to make sure the backups do not get removed. Then indeed enable file backups again, it could/should run a file backup in no-time since there is not much to backup. You can then try the restore again. I guess this could be a bug. Maybe start by restoring just a small part of the backup, to see if that works. But i guess depending on the complexity of the (meta)data and volume it could take a long time before anything starts happening. Dont forget to check that archive box, since you disabled file backups that might even mean the file backups will be removed in the next maintenance window (i am not sure about that, but better to be safe than sorry).

1 Like

Same error and backup is enabled… How to restore now? :face_with_raised_eyebrow:
Error: “Starting restore failed: disabled”

What do the logs say?

I changed this to client config (was disabled)
and now log says
“Restore was inactive for 5min. Timeout. Stopping restore…”

Server UrBackup 2.5.31
UrBackup Client Controller v2.5.23.0

Trying to update client to 2.5.24 now and testing again.

Upgrading to client 2.5.24 helped. Restoring works now.

1 Like